Showing results for 
Search instead for 
Did you mean: 
Advocate II
Advocate II

Direct Query connectivity issues with Redshift in the last few days; Production reports won't load

We've got a few Direct Query reports pointing at a Redshift cluster. This has worked great the last few weeks but over the last two or three days, we're getting schema load errors when attempting to render these reports.

When we attempt to refresh the data, we're seeing that there's an issue loading the Redshift ODBC driver (see below).

@Microsoft - Is this a known issue? Is it possibly related to a recent PBI release?

At this point, we're dead in the water with these reports and really need this to be working again.


Here's the detailed error:


Something went wrong
There was an error when processing the data in the dataset.
Please try again later or contact support. If you contact support, please provide these details.
Data source error: ODBC: ERROR [IM003] Specified driver could not be loaded due to system error  126: The specified module could not be found. (Simba Amazon Redshift ODBC Driver, D:\SvcFab\_App\analysisserver.backendapptype_App5741\analysisserver.backend.servicepackage.Code.2018.11.4.37\workloads\AS.2018.11.4.204\MDataEngine\ODBC Drivers\Simba Amazon Redshift ODBC Driver\AmazonRedshiftODBC_sb64.dll).. The exception was raised by the IDbCommand interface. Table: opp_dim_npi.
Cluster URI:
Activity ID: 1111043c-4262-4aaa-a740-5b19114b17ba
Request ID: c88b2953-366e-81db-61ce-35cedefa04ce
Time: 2018-12-03 03:45:19Z


- Terence



Not applicable

The problem occurs again for us.


Connect on LinkedIn

Getting this issue now for import mode models in in both and


Credentials need to be entered now after this refresh was working earlier.


When I attempt to enter credentials, I get this error.

Failed to update data source credentials: ODBC: ERROR [IM003] Specified driver could not be loaded due to system error 126: The specified module could not be found. (Simba Amazon Redshift ODBC Driver, D:\SvcFab\_App\ASAzureApp_App1\DataMovementMetadataServicePackage.DataMovementMetadataService.Code.Main_13.0.11747.192_1912151804\ODBC Drivers\RS\AmazonRedshiftODBC_sb64.dll)

Not applicable

Same here! Some acknowledgement of the issue and timeline to fix it would be great -- we are also dead in the water, with business processes depending on these reports!!

Not applicable

I've got confirmation that this a problem with the current premium/embedded release build. No ETA for a fix though... Will get an update later today (CET).

Not applicable

Going to be fixed tonight according to my information.

Not applicable

Thanks for sharing. The extreme lack of response to tickets and lack of any public messaging about the problem is a huge concern.

Not applicable

I agree. We are not working on some toy projects here, but serious business applications. The issue is not resolved for us at the moment. There was a brief interval during which it has been working, but not anymore.
Continued Contributor
Continued Contributor

This appears to be fixed for us, since ~11:00 p.m. last night (Pacific). We've had 9 consecutive successful (hourly) refreshes since then.


Our dataset is in Premium capacity and its data source is Redshift. But our situation might be a bit different, in that our dataset is in Import mode, not Direct Query.

Not applicable

This seems to be fixed for us, too. However no one from Microsoft ever told us that it was fixed or told us to try again. Thanks to others here reporting success, I manually refreshed datasets and we re-embedded our Direct Query report and it is working as of right now. I hope others have success, too.

We ran into this issue again about an hour ago. Appears to be working now but we're skeptical that this is really fixed.

Can we please get some sort of response from @ms on this? If it's still in progress, let us know and we can at least set expectations with our users.

Continued Contributor
Continued Contributor

Yeah, it actually just started happening for us, again, a few hours ago.

Not applicable

Yepp, we eperienced a regression over the weekend as well, as of now, this seems to be resolved for now.

Not applicable

Same here. Every report connected to Redshift fails. No response from Microsoft. Unbelievable!

This is just silly. We're paying for premium capacity and, as a result, we're dead in the water on this issue with little to no response from Microsoft support.

Can we please get some sort of official response from MS on this? Their service status page is reporting that all is good... 😞

Community Support
Community Support

Hi @tmcdevitt,


I check you request id and found the trace log mentioned:


Processing for d736c535-0ea6-4671-b2ce-6718e5bb4d3d failed due to managed provider error Failed to save modifications to the server.


Processing for database d736c535-0ea6-4671-b2ce-6718e5bb4d3d with max parallelism 6 failed because of amo exception Microsoft.AnalysisServices.OperationException: Failed to save modifications to the server.


It seems like something wrong with with operation with save changes, maybe you can open a support ticket for this.


Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.
Not applicable

But: Direct Query doesn't save changes. The failed save operation must be in the PowerBI stack. I've tested this with a fresh and small PowerBI report using Redshift in Direct Query mode. Same error. This means to me that Redshift atm doesn't work at all when using dedicated capacity. This is really hurting anyone who made a decision to use PowerBI in production mode with Redshift as database. Of course I also opened a support ticket.


We have applications in production and paying customers. How is this happenning and why is nobody at Microsoft taking care of this? 

Regular Visitor

We have the same problems with updating dataset when it is comming from Redshift.

Problem ocurrs only when datasets are stored on Premium Capacity instances.

Not applicable

Same here 😞 Really hurting us in prodution. We use PowerBI Azure Dedicated Capacity. Works fine in App Workspaces without dedicated capacity.

Helpful resources

PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!


Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors
Top Kudoed Authors