cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jengwt Member
Member

Different users seeing different numbers *not security*

Hello, I have users who are inexplicably getting different results from the same report.

I built this report several months ago, but have since switched departments. The current curator of the report came to me saying that data isn't populating for herself and the vast majority of users.

 

So we did some investigating:

- I can still see all of the data, but she and the users can't, neither she on her desktop copy, nor her nor them on the Server version.

- Data refreshes have been working fine.

- Security code has remained the same, and none of the tables related to the security fields have changed. Security is properly applying to users, the data simply isn't there for them.

- In fact, nothing about any of the tables has changed.

- User access has remained the same.

- She and I are the two primary admins, and we have the same permissions and same version of PBI. We publish to a premo workspace.

 

- Now this is extra strange; we swapped local copies and with her copy I got the same results that my local copy produced, and the copy I sent her produced for her the same results as what her copy produced for her.

- Our local copies use our DB creds, but the copy in Server refreshes using a PID via a gateway. Data sources are both Dynamics and an IBM DB2 DB.

- Incrimental refresh is not used. Even if it was, we would have seen it when we swapped copies.

 

All of this seems to point to some sort of security issue, but I haven't the slightest idea why it is occuring. Everything that I can think of is exactly the same between us.

This came to our attention about three weeks ago (so, late September). I was only contacted abot it last week.

What is going on?

 

Below you can see the two variants of data that people are seeing. Note the massive differences. The first one is correct, the second is utterly wrong. Yes, for privacy I redact my screenshots. There's nothing there you need to see.

MyversionRedacted.pngHerversionRedacted.png

I created a Issue for this in case it isn't forum-worthy: https://community.powerbi.com/t5/Issues/Different-users-seeing-different-numbers-not-security/idi-p/...

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
jengwt Member
Member

Re: Different users seeing different numbers *not security*

We discovered that it was, in a manner of speaking, a creds issue.

 

When I had passed the report along, the new caretakers had their DB connections set to use Windows authentication, not Database. At some point they re-uploaded the report, at which time I guess their connection settings overwrote mine from the old copy. So now, the report was attempting to use Windows authentication with the creds for the PID that does the refreshes?

This for some reason was not crashing the refreshes, but the refreshes were either not occuring or just pulling nothing. The only data available to the report was cached data, so in time the data in a time frame that the users were wanting to see was daily decreasing.

 

We simpy changed the connection type back to Database, and everything started working again.

 

I had forgotten that connection settings are local app settings, and not carried with the report. That explains why the data all looked correct to me, even on both copies of the report.

3 REPLIES 3
Super User
Super User

Re: Different users seeing different numbers *not security*

Hi there

I would say that it appears to be security related, because you as the author can see everything.

Can you confirm that the Security Settings for the dataset are still intact, and that everyone who should be in each group is actually in the Roles and has the correct access?

Did I answer your question? Mark my post as a solution!
"Proud to be a Datanaut!"
Power BI Blog
Community Support Team
Community Support Team

Re: Different users seeing different numbers *not security*

Hi @jengwt,

 

You can create a ticket for help here.

 

https://powerbi.microsoft.com/en-us/support/

 

Regards,

Frank

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
jengwt Member
Member

Re: Different users seeing different numbers *not security*

We discovered that it was, in a manner of speaking, a creds issue.

 

When I had passed the report along, the new caretakers had their DB connections set to use Windows authentication, not Database. At some point they re-uploaded the report, at which time I guess their connection settings overwrote mine from the old copy. So now, the report was attempting to use Windows authentication with the creds for the PID that does the refreshes?

This for some reason was not crashing the refreshes, but the refreshes were either not occuring or just pulling nothing. The only data available to the report was cached data, so in time the data in a time frame that the users were wanting to see was daily decreasing.

 

We simpy changed the connection type back to Database, and everything started working again.

 

I had forgotten that connection settings are local app settings, and not carried with the report. That explains why the data all looked correct to me, even on both copies of the report.

Helpful resources

Announcements
Community Kudopalooza

Win Power BI Swag with Community Kudopalooza!

Each week, complete activities and be qualified in the drawing for cool Power BI Swag.

Summit North America

Power Platform Summit North America

Register by September 5 to save $200

Virtual Launch Event

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

MBAS Gallery

Watch Sessions On Demand!

Continue your learning in our online communities.

Top Kudoed Authors
Users Online
Currently online: 287 members 2,811 guests
Please welcome our newest community members: