cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

Date format in PowerBI Desktop client is different than the one published. Sorting doesn't work

Hi everyone!

 

I have a strange issue. 

 

I sort my report by date in this format. 02-Nov-17 9:59 AM etc. When i use the PowerBI Desktop , it sorts the report fine.

 

When i publish it , the date is displayed in this format 09-02-17 . So because of this the sorting is not working correctly online.

 

 

How can i fix this?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Regular Visitor

Re: Date format in PowerBI Desktop client is different than the one published. Sorting doesn't work

I managed to fix this . You can now change the local of specific date columns. It worked !

View solution in original post

3 REPLIES 3
Regular Visitor

Date format in PowerBI Desktop client is different than the one published. Sorting doesn't work

Hi everyone!

 

I have a strange issue. 

 

I sort my report by date in this format. 02-Nov-17 9:59 AM etc. When i use the PowerBI Desktop , it sorts the report fine.

 

When i publish it , the date is displayed in this format 09-02-17 . So because of this the sorting is not working correctly online.

 

 

How can i fix this?

Highlighted
Regular Visitor

Re: Date format in PowerBI Desktop client is different than the one published. Sorting doesn't work

I managed to fix this . You can now change the local of specific date columns. It worked !

View solution in original post

Highlighted
Microsoft
Microsoft

Re: Date format in PowerBI Desktop client is different than the one published. Sorting doesn't work

Hi @shak,

 

Here is a similar thread in which the reason of this issue and the workaround are mentioned. Could you go check if it helps in your scenario? Smiley Happy

Hi all,

 

Fixed it!!!! - Well my DBA colleague found the solution.

 

The reason it was working for some users and not others is the following:

 

When a user had their default language set to English UK then their language setting in Power BI would remain unset.
When a user had their default language set to English US then their language setting in Power BI would get set to English.


(This is why we had some users working properly)

 

There appears to have been an update on the Power BI Service recently that allows you to set the language setting to respect the browser settings again.


(This was not the case earlier this year http://community.powerbi.com/t5/Service/Language-Settings-Power-BI-Cannot-set-to-British-English/td-... )


This means, you can now correct your language in your browser and then setting the Power BI Service language to default and the issue should be fixed.

 

To do this:

 

Change your browser language to English (UK) (or relevant language).

 

IE: Set IE Default Language (same for IE 11)

 

Chrome: Set Chrome Default Language


Then, in the Power BI Service, under Settings > Language, set it to Default (browser language).

 

Choosing this means the dates in my reports are now in the correct format, DD/MM/YYYY. Smiley Happy



 

Regards

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Find your favorite faces from the community presenting at the Power Platform Community Conference!

Upcoming Events

Experience what’s next for Power BI

See the latest Power BI innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Upcoming Events

Community Summit North America – Join Online!

Join this community-driven Power Platform digital event for unbiased support and problem-solving.

Top Solution Authors