cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ccharker
Frequent Visitor

Date Format

Hi, I am an Australian user of Power BI.

Since commencing to use Power BI, my date formats have been displaying in the format dd/mm/yyyy (which is correct for my locale).

This morning, I was reviewing my setting in Power BI Service, and noticed that I did not have a language set. I updated my language to English, and it was not converted all displayed dates to US format mm/dd/yyyy. I cannot change it back to being correct for AUS, and I cannot remove the language setting.

System would appear to assume that if your language is English, then your date format is mm/dd/yyyy (which is just wrong).

Can you please advise if this can be fixed.

5 REPLIES 5
ccharker
Frequent Visitor

Date Format

Hi,

I am an Australian user of Power BI.  Since commencing to use Power BI, my date formats have been displaying in the format dd/mm/yyyy (which is correct for my locale).

This morning, I was reviewing my setting in Power BI Service, and noticed that I dod not have a language set.  I updated my language to English, and it was not converted all displayed dates to US format mm/dd/yyyy.  I cannot change it back to being correct for AUS, and I cannot remove the language setting.

 

System would appear to assume that if your language is English, then your date format is mm/dd/yyyy (which is just wrong).

 

Can you please advise if this can be fixed.

BhaveshPatel Community Champion
Community Champion

Re: Date Format

See if this can fix your issue.

 

Power BI detects your language based on the language preferences on your computer. The way you access and change these preferences may vary depending on your operating system and browser. Here's how to access these preferences from Internet Explorer and Google Chrome.

Internet Explorer 

  1. Click the Tools button in the top-right corner of your browser window:

  2. Click Internet Options.

  3. In the Internet Options dialog, on the General tab under Appearance, click the Languagesbutton.

Google Chrome 

  1. Click the menu button in the top-right corner of your browser window:

  2. Click Settings.

  3. Click Show advanced settings.

  4. Under Languages, click the Language and input settings button.

  5. Click Add, select a language, and click OK.

    The new language is at the end of the list.

  6. Drag the new language to the top of the list, and click Display Google Chrome in this language.

    You may need to close and reopen your browser to see the change.

Thanks & Regards,
Bhavesh

Love the Self Service BI.
Please use the 'Mark as answer' link to mark a post that answers your question. If you find a reply helpful, please remember to give Kudos.
Microsoft
Microsoft

Re: Date Format

Hi @ccharker,

 

The workaround provided by BhaveshPatel should fix this issue. In addition, here is a similar issue for your reference.

 

Regards

ccharker
Frequent Visitor

Re: Date Format

Hi Bhavesh,

thanks for your response, but it does not resolve the issue that I am experiencing.

 

My language setting is English (Australian).

 

All otehr browser apps that display dates show as correct dd/mm/yyyy.  However, when I updated the Language setting in Power BI Service from blank (which is what it was), to English (which is what I now have it set to), the date formats for all my Power BI reports and dashboards changed from dd/mm/yyyy to mm/dd/yyyy. 

 

I can't seem to change it anywhere, or remove the language setting in Power BI Service so that my date formats go back to the correct format.  It appears that the system is set that if your language is English, then your date format is mm/dd/yyyy, which is just not correct.

 

Is there any way to fix this, or do I now need to change all my reports / dashbaords which is not a good experience, and will probably be the death of using this service in my organisation.

Super User IV
Super User IV

Re: Date Format

@ccharker could you possibly see what your setting is set to in IE as shown below.

 

Open Internet Explorer (Yes I know this does not make sense, but it does appear to control all browsers), click on Settings and then Internet Options.

 

Then as shown below click on Lagnuages, and then see if you have got English (Australia) [en-AU] at the top of your list?

 

If not, put it at the top and if possible remove all other ones.

 

Power BI - Australian Date Settings IE.png

Hopefully that will resolve your issue?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!






Power BI Blog

Helpful resources

Announcements
‘Better Together’ T-Shirt Contest – Winner Announced!

‘Better Together’ T-Shirt Contest – Winner Announced!

And the winner is...

Announcing the New Spanish Forum

Announcing the New Spanish Forum

Do you need help in Spanish? Check out our new Spanish community section.

Attending MBAS? Claim your badge

Attending MBAS? Claim your badge

Whether you’re streaming the digital event live, or watching on-demand, claim your attendee badge to sport on your profile.

April 2020 Community Highlights

April 2020 Community Highlights

Info on our Super Users, MBAS content and badges, and updates to our support articles. - Read the full Community Highlights.

MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.