cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
agenovese Frequent Visitor
Frequent Visitor

Date Filter not working in PowerBI when Uploaded from Desktop

I have a dataset that I prepared using PowerBI desktop. It contains a date column called tDate.  When I upload this PowerBI and start using the Q&A, it does not slice/filter the data correctly. For example, if I ask "Show Total PaidAmt" it will show 30M, representing the total paid over the entire data set.  If I type in "Show Total PaidAmt in last two weeks" I see the DATE filter pop up correctly in the report, but it doesnt show the correct information. It still shows 30M.

 

I tried a new dataset and the same thing happened. Everything was working fine, then I upgraded the powerBI desktop to the lastest version and have not had success since.

 

Interestingly, when i try to see the dates "Show tDates" it only shows one date. 1/1/2015. (I have data from 2012 to today).  If say "Show tDates in last week" the Q&A helper pops up the following suggestion.

"Show date table template a 04189 0f 1030 4975 ace 9 6158 9afb 8f 54 and their date where date is last week"

 

Mannualy dragging the tDate column to the filter and applying it DOES work correctly.

 

Any ideas? Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
agenovese Frequent Visitor
Frequent Visitor

Re: Date Filter not working in PowerBI when Uploaded from Desktop

I fixed the issue by going into PowerBI->Options and Settings->Options-> Current File-> Data Load-> Uncheck Auto Date/Time

 

Saved, published, *Cleared IE's Browser History* and it worked.

 

*Note, I did try  clearing the brower history prior to this, so it wasn't the only issue. Maybe you don't need to do it, who knows. Just letting you know the exact steps I took to fix it.

2 REPLIES 2
Highlighted
agenovese Frequent Visitor
Frequent Visitor

Re: Date Filter not working in PowerBI when Uploaded from Desktop

I fixed the issue by going into PowerBI->Options and Settings->Options-> Current File-> Data Load-> Uncheck Auto Date/Time

 

Saved, published, *Cleared IE's Browser History* and it worked.

 

*Note, I did try  clearing the brower history prior to this, so it wasn't the only issue. Maybe you don't need to do it, who knows. Just letting you know the exact steps I took to fix it.

agenovese Frequent Visitor
Frequent Visitor

Re: Date Filter not working in PowerBI when Uploaded from Desktop

The December PowerBI Desktop update did NOT fix this. Auto Date/time is still not working.