cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Regular Visitor

Dataflows always fail to refresh due to "internal error"

I cannot seem to get a single dataflow to work. Even the most simple dataflow that doesn't connect to any data source and just returns static data will fail to refresh with the error:
 
Error: Internal error Request ID: 67d17199-9d7f-23ca-59f0-aa5534b1b9e2 Activity ID: ec2ef1d5-5e76-4cc7-98b4-da9d03db843a
 
or similar. I've tried everything...different data sources, credentials, different app workspaces. Nothing seems to make any difference, and I can't find any details as to why. Other uses seem to get this issue for a variety of reasons but none seem to apply to me.
 
I'm starting to wonder if it's an account based issue, but I don't know how to access any deeper diagnostic information.
 
Suggestions appreciated.

1 ACCEPTED SOLUTION
Regular Visitor

Hi Davolsen,

 

 

I've just looked into the logs base on the request Id you provided us. We saw the same problem from other customers and engineering team is working on a fix. We will update you as soon as the fix will be in place.

 

Thanks,

Galia

View solution in original post

25 REPLIES 25
New Member

I have a similar problem: 

Error: Internal error Request ID: ffec99ef-b8e2-4ded-a47d-3171a15e2b7f Activity ID: d5e28c5d-e7e6-46f4-ad8c-07be6c4b42
 
Could you help resolve the issue please?
New Member

I have a similar problem, the data flow stops and gives an "Internal error" for no reason.

Help solve the problem!


Internal error Request ID: 6443116f-2819-3393-31e5-036f45eaca26 Activity ID: 00000000-0000-0000-0000-000000000000 {"RootActivityId":"6443116f-2819-3393-31e5-036f45eaca26"}

Frequent Visitor

Can someone update my dataflows?

 

I'm with serious problems, i need this update

 

Cluster URIWABI-US-NORTH-CENTRAL-redirect.analysis.windows.net
ID da atividadec340c107-ac53-42fd-a370-9c9bd61e60ff
Solicitar ID49eda8b9-fd48-49be-90cf-a65acb80ddd1
Hora2019-12-05 12:21:48Z

I advice you to submit a support ticked. 

 

let me know how it goes.

 

Here's the link: 

https://powerbi.microsoft.com/en-us/support/pro/

Same issue on my side. I do have multiple dataflows, which are all connecting to the same SharePoint directory. For some reason two of them work, and 5 others doesn't... 

Is there an update from the team working on this issue? Is the fix already in place, or maybe a suggested workaround? 

Thanks in advance, 
Marc 

Hi Marc, can you please add Request ID and Activity ID (from history excel)?

Thanks

Batchen

Hi @Batchen_Haviv 

Tanks for asking. 
Hereby the log of one dataflow (out of 5 current failing dataflows).

 

Error: Internal error
Request ID: 6ecd61df-4e53-1a7d-4a42-7b2184f69d33
Activity ID: 9a551e6a-7a58-451d-9d9c-76a7f0159821

 

Thanks in advance! 
Marc

Hey Marc

 

We are aware of this problem and a fix should be available by the end of week.

 

If you wish to overcome it immediately you can rename your entities so they include only letters, numbers and spaces (no special characters) and also verify they don't start with a number.

 

Thanks

Batchen

 

I get other error every time when I'm trying to refresh the dataflow:

AzureBlobs failed to get the response: 'Unable to connect to the remote server'. Request ID: 678316e9-7984-55c0-0e87-1f6bd6cd0ea5 Activity ID: 00ebce37-f7cd-4482-83e7-0b68ecb3be59

 

It's pretty weird because when I create a dataflow It get the preview data every time.

What I should do?

Regular Visitor

Hi Davolsen,

 

 

I've just looked into the logs base on the request Id you provided us. We saw the same problem from other customers and engineering team is working on a fix. We will update you as soon as the fix will be in place.

 

Thanks,

Galia

View solution in original post

Frequent Visitor

Hi there, I am getting the same issue. Is there a fix for it yet?

 

Cluster URI: WABI-SOUTH-CENTRAL-US-redirect.analysis.windows.net
Activity ID: 90587c35-4f7f-46c3-b6fb-d1d75f179b90
Request ID: 81f222fa-2260-3f65-8a6e-7f86bfa1893a
Time: 2019-06-14 14:59:20Z

 

Thanks!

Karina

I now seem to have the same error

Error: Internal error

Request ID: ceb6af97-8ebb-49e9-8f21-0293be46a68d

Activity ID: f3bc5d3d-1db0-4734-83e3-14f712133676

HELP!!!

 


@korpek wrote:

Hi there, I am getting the same issue. Is there a fix for it yet?

 

Cluster URI: WABI-SOUTH-CENTRAL-US-redirect.analysis.windows.net
Activity ID: 90587c35-4f7f-46c3-b6fb-d1d75f179b90
Request ID: 81f222fa-2260-3f65-8a6e-7f86bfa1893a
Time: 2019-06-14 14:59:20Z

 

Thanks!

Karina



Nope. There is no fix for this issue. I continue to use old datasets with my personal gateway. It's disaster!

It's unfornally for Microsoft, that I'm having the same issue almost 6 moths later. 

Hi @Ustinovdl  @korpek 

 

It seems to be that you're refering to a different case than mine was. For me the issues are all fixed and where related to a temporary bug with the entity and dataflow names. All fixed as mentioned by @Batchen_Haviv  in earlier posts. 

So, if it is not the same, you probably can better open a new topic. 

 

Regards, 

Marc 

https://data-marc.com/

 

 

Same problem since 2 days. Impossible to close the dataflow. Yet, it's been working fine for 3 months. The refresh works  but I can no longer make any change. 

 

So disturbing !!!

 

Marc

ID d'activité: e970b637-efbb-42e9-8d06-3dfa37aabbd3

ID de demande: 8fdd4d87-9a0e-e101-b0fd-6faf734e3d7d

ID de corrélation: 9e27ce15-ace9-6ebb-8046-da2787709e6b

Code d'état: 500

Heure: Mon Jul 01 2019 22:57:05 GMT+0200 (heure d’été d’Europe centrale) Version: 13.0.9933.240 URI du cluster: https://wabi-europe-north-b-redirect.analysis.windows.net

Anonymous
Not applicable

I am getting the same error on dataflows. The data was working and then it started failing to refresh. I tried deleting the table and re-adding it, as well as logging on and off. 

 

This is the error I am getting when I download the excel file:

 

Error: Internal error Request ID: bc8283d5-d44d-406e-f803-e3e94f06b986 Activity ID: 2672c6b9-184a-45c7-aaf6-4ad7be05693c

Hi verballi2,

 

We are aware and a fix should be available by the end of week.

 

If you wish to overcome it immediately you can rename your entities so they include only letters, numbers and spaces (no special characters) and also verify they don't start with a number.

 

Thanks

Dotan Marcus

Hi verballi.

The root cause of your problem is not the same as this thread problem. I am investigating your problem, will update once I will have more information.

Batchen

I just tested my data flows and they are now refreshing.

 

Looks like the issue is fixed for the moment!

Helpful resources

Announcements
secondImage

Experience what’s next for Power BI

Join us for an in-depth look at the new Power BI features and capabilities at the free Microsoft Business Applications Launch Event.

secondImage

Power BI Women

Join our monthly meetings and learning sessions.

secondImage

Congratulations!

We are excited to announce the Power BI Super Users!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors