cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Dataflow - Refresh Issue - Query works fine, when refreshing this comes up..

Hi All,

 

So I have just gotten access to a Company Gateway and wanted to test setting up a dataflow. The query designer runs fine and there are no issues when validating the query. 

 

However when I want to manually refresh the dataflow it gives me the error below, but I have no idea on what it is actually giving the error.. It doesn't state any column? My datatypes are all correctly set up I think? (see pictures included)

 

Error:

Invalid date,TEST DATA FLOW 1 to refresh,Mislukt,Fact PL Data - TEST DATAFLOW,21/11/2019 17:32:13,21/11/2019 17:32:48,Mislukt,Error: We couldn't convert to Number... RootActivityId = c8cac63c-ae27-4a63-871d-c1aa721ac28e.Param1 = We couldn't convert to Number. Request ID: 4d1a7298-5a18-1d91-8d67-d2ecbeb1a59a.

 

Can someone give me some more info on why this is happening? No idea how I can figure out here what went wrong..

 

1.PNG

4 REPLIES 4
Frequent Visitor

Do you have a conditional column in the query somewhere?

Anonymous
Not applicable

 

EDIT:  I tried to load the raw data without any extra step in the query (so no conditional columns). 

 

I tried this multiple times for different Excel files in my folder (which have the exact same columns and row data) and which load perfectly normal in desktop version when published => Somehow for some Excel files it randomly gives this exact same error.. And for some Excel files it doesn't..

 

It seems to be totally random and I have no idea why it's happening.. All of the data in the Excel files is exactly the same and it should make no difference at all..

 

I tried refreshing with 2 Excel files are in the folder => It works

I add 2 random excel files => Stops working..

I delete those 2 random excel files giving the error so that I just have those 2 original ones which were working => Stops working...

 

So this behaviour seems totally random and I don't know what is causing this..

 

This really seems like a bug..

 

Anonymous
Not applicable

Bumping to the top, I really don't understand this error and it seems to be a bug in my opinion..

I'm using sharepoint folder as connector, in that also I'm getting same error in the dataflow.

 

I've first created a code in Power BI Desktop, there the code was working perfectly, now I copy & pasted the code to my dataflow, and added credentials, but if I'm refreshing my dataflow, I'm getting same error.

 

Error message: 

 

Error: DataFormat.Error: We couldn't convert to Number. (.. RootActivityId = cf3a5bf9-106a-4c82-94bd-f855b92f7aca.Param1 = DataFormat.Error: We couldn't convert to Number. ( Request ID: ba9ff2ea-e988-49f3-8e85-a36235a6fc8f.

 

Do anyone have an idea, why this kind of issue is happening

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors