cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Chiranjit
Frequent Visitor

Data refresh issue in power bi service

I have created a report in power bi dekstop and published to power bi service. The data source is a sql server databse.  I have installed an on-premise gateway. In manage gatways in service it is showing that the gateway is online. But the  refresh is not happening.

The following error messege is shown when I am trying to refresh the data in power bi service.

 

Something went wrong
Invalid connection credentials.
Please try again later or contact support. If you contact support, please provide these details.
Cluster URIWABI-WEST-US-redirect.analysis.windows.net
Activity ID5a85755f-ea91-f480-123d-eafd36de95be
Request IDcd4dcb69-c6a7-498a-41a1-aa45da063c70
Time2018-04-13 12:37:33Z
1 ACCEPTED SOLUTION

 The issue is resolved. I was using the server shortname but the certificate had the FQDN.  So i used the FQDN in the connection so that the connection string matches the certificate.  Now i can refresh the data.

View solution in original post

4 REPLIES 4
v-yuta-msft
Community Support
Community Support

Hi Chiranjit,

 

Based on the information you have provided, the error type is "Gateway_InvalidConnectionCredentials", please click gateway management and check if the credential is wrong.

 

In addition, could you please tell me if you are connecting to Sql Server Database or Sql Server Analysis Service? If you are connecting to AS, you should configure user mapping, please refer to this documentation:https://docs.microsoft.com/en-us/power-bi/service-gateway-enterprise-manage-ssas#map-user-names.

 

For further troubleshooting, could you provide your gateway log to me if the error still occurs?

 

Regards,

Jimmy Tao

richardlhughes
Responsive Resident
Responsive Resident

Hi @Chiranjit,

 

I would check to ensure that you have appropriately setup the gateway datasrouce. You will see in the gateway settings if the gateway cannot connect to the data source then you will see a yellow exclamation next to your datasource from the gateway settings.

 

After confirming the gateway is not hte issuse, you should check in your workspace under the dataset settings, you should see the Data source creditial section, make sure that you haven't missed anything for this dataset setup.

The gateway is online. Data source credentials are also correct. Data source connection is successful.  But it is still showing invalid connection credentials error message while data refresh.

 The issue is resolved. I was using the server shortname but the certificate had the FQDN.  So i used the FQDN in the connection so that the connection string matches the certificate.  Now i can refresh the data.

View solution in original post

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Solution Authors