Reply
Frequent Visitor
Posts: 4
Registered: ‎10-06-2017
Accepted Solution

Data discrepancy between PBI Service and PBI Desktop

Hi,

 

I am fairly new to PBI and have generally found solutions/answers to my issues/questions I've encountered thus far on the community posts -- this has been an amazing resource to help me learn PBI.  So I want to thank everyone who have contributed and thank the ones who will be able to help me with my current issue.

 

I have a report with one value in Desktop (the correct value) and the incorrect value in Service.  Upon initial publishing both values are correct.  After publishing, I added a refresh schedule and then envoked the 'REFRESH NOW' process:

 

Refresh Now.png

The on demand refresh took about 20 minutes, but was completed succesfully:

Refresh history.png

 

The values on the PBI online has now changed.Service-ReprotAll.pngReport from ServiceDesktop-ReportAll.pngReport from Desktop

What I've done so far to trouble-shoot:

1. Verify that the correct data is what the Desktop is showing, but refreshed the desktop report anyways

2. Deleted the report/dataset in PBI service and republished - values were in sync, but after refreshing data was off again

 

Other info:

Data source is D365 for Finance and Operations (via ODATA)

 

Please let me know if there are other information I can provide that would help.

 

Thank you!

 

Kevin


Accepted Solutions
Highlighted
Frequent Visitor
Posts: 4
Registered: ‎10-06-2017

Re: Data discrepancy between PBI Service and PBI Desktop

Update on this issue.  I opened a ticket with support and it is a known issue.  The bug is related to visual filters with Boolean values.  In Power BI Desktop the values are True/False, however when published to Power Bi Service the values were changed to -1/0.  The filtered value was True but in Power BI Service there was not value = True which basically rendered that filter useless.

 

 

Desktop.jpgDesktopServices.jpgServices - converted values to -1/0 but left the 'TRUE' value select. All Boolean data was converted so no values = True

 

Support provided a couple of work arounds:

 

1. Update data in Power BI Desktop to text value then republish

2. In Power BI Services manually select the filters to -1/0 after pubishing.  Note: each time you publish it will be overwritten.

 

PS. Suport was very helpful and responsed withn two hours from when I opened my ticket.

View solution in original post


All Replies
Super Contributor
Posts: 3,697
Registered: ‎07-17-2016

Re: Data discrepancy between PBI Service and PBI Desktop

Hi @KevinSanDiego,

 

How long does the refresh take on Power BI Desktop? Is it also 20 minutes?

 

All I can expect is that there may be some data updates during these refresh durations. Or it turns out to be an issue with Power BI service, in which case you may need to create a support ticket on Power BI Support page to report the issue and for better assistance. Smiley Happy

 

Regards

Frequent Visitor
Posts: 4
Registered: ‎10-06-2017

Re: Data discrepancy between PBI Service and PBI Desktop

@v-ljerr-msft yes the desktop takes about 20 minutes as well.  You mentioned that "there may be some data updates during these refresh durations"  if there are data changes does that cause to the refresh to return incomplete/bad data?  It is likely that are data updates, however I do have a schedule run late evening when no one is in the system and the data in PBI service is still off.

 

Thank you for your reponse.  I will open up a ticket with Power BI Support.

 

Warm regards,

 

Kevin

Highlighted
Frequent Visitor
Posts: 4
Registered: ‎10-06-2017

Re: Data discrepancy between PBI Service and PBI Desktop

Update on this issue.  I opened a ticket with support and it is a known issue.  The bug is related to visual filters with Boolean values.  In Power BI Desktop the values are True/False, however when published to Power Bi Service the values were changed to -1/0.  The filtered value was True but in Power BI Service there was not value = True which basically rendered that filter useless.

 

 

Desktop.jpgDesktopServices.jpgServices - converted values to -1/0 but left the 'TRUE' value select. All Boolean data was converted so no values = True

 

Support provided a couple of work arounds:

 

1. Update data in Power BI Desktop to text value then republish

2. In Power BI Services manually select the filters to -1/0 after pubishing.  Note: each time you publish it will be overwritten.

 

PS. Suport was very helpful and responsed withn two hours from when I opened my ticket.