cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mhershey84 Frequent Visitor
Frequent Visitor

Data Source Credentials Sign In Hangs

Hello,

I have been using the personal gateway to connect to our SQL server for our Power BI reports on the Web Service for a few months with no problem. As of yesterday, I get the following error when I try to refresh any of our reports: "Your data source can't be refreshed because the credentials are invalid. Please update your credentials and try again."

When I try to sign in with my credentials, it hangs and the dots spin after I click Sign In. It does not give an error even if I try to sign in with intentionally wrong credentials it just stays hangs indefinitely. So far, I have tried reinstalling Power BI desktop and the personal gateway, different authentication methods, deleting and reuploading the reports, and different browsers. Any help would be appreciated.

5 REPLIES 5
nexter8 Frequent Visitor
Frequent Visitor

Re: Data Source Credentials Sign In Hangs

try set blank privacy level.

i have the same problem https://community.powerbi.com/t5/Service/can-t-update-Data-Source-Credentials/m-p/666336/highlight/f...

 

for ms sql it work

mhershey84 Frequent Visitor
Frequent Visitor

Re: Data Source Credentials Sign In Hangs

Thanks for the insight, that seemed to do the trick.  I deleted all of our reports off the web service and then reuploaded them and was able to sign in with the privacy level blank.  It'd be nice to know what is causing the issue though since its a huge hassle to need to delete and reupload if this happends again.

keithdbates Frequent Visitor
Frequent Visitor

Re: Data Source Credentials Sign In Hangs

Anyone finding that even deleting and republishing doesn’t work? The blank privacy option worked before but is now gone.
nexter8 Frequent Visitor
Frequent Visitor

Re: Data Source Credentials Sign In Hangs

@mhershey84  I removed cookie and can update credentials.

keithdbates Frequent Visitor
Frequent Visitor

Re: Data Source Credentials Sign In Hangs

Looks like service is working again.  No need to remove cookies for me.  Just re-tried monday morning.