Showing results for 
Search instead for 
Did you mean: 
Regular Visitor

Data Source Credentials Greyed out



I have a simple query that retrieves the time from a website. The query works in Power BI desktop and I can publish it to Power BI online Workspace. I want to be able to refresh the dataset in the published online version but it will not let me, it is greyed out.


This is the query from the desktop:

    Source = Web.Page(Web.Contents("")),
    Data = Source{1}[Data],
    #"Changed Type" = Table.TransformColumnTypes(Data,{{"Column1", type text}, {"Column2", type text}}),
    #"Transposed Table" = Table.Transpose(#"Changed Type"),
    #"Promoted Headers" = Table.PromoteHeaders(#"Transposed Table", [PromoteAllScalars=true]),
    #"Changed Type1" = Table.TransformColumnTypes(#"Promoted Headers",{{"Current local time:", type time}, {"Date:", type date}, {"Time zone:", type text}, {"Current time zone offset:", type text}, {"Twitter Share", type text}}),
    #"Added Custom" = Table.AddColumn(#"Changed Type1", "Custom", each [#"Date:"] & [#"Current local time:"]),
    #"Changed Type2" = Table.TransformColumnTypes(#"Added Custom",{{"Custom", type datetime}})
    #"Changed Type2"

And this is a screenshot of the greyed out Data Source Credentials:



Why can't I schedule this to refresh??

Not applicable

I have the same exact issue in many workspaces, my datasources are Sharepoint online, excel, etc. however I took over those datasets and cant change credentials.
- I can't install personal gateways. Its not a solution

- All data sources are online.


Please help

Gabriel Villayzan

I'm facing the same issue !! Please let me know if you find the solution. 

Regular Visitor

I'm facing the exact same issue, and have tried the solutions provided by amazing helpers in the comments (thanks!) but no luck.

- I can't install personal gateways due to company laptop's restriction 

- All data sources on Sharepoint Online (not on premise, and no local files)


Not sure if there is any more solutions on this issue? Thanks in advance everyone!

Advocate I
Advocate I

Hi, for me the issue was that although my main query took data from sharepoint, I had another query drawing data from a seperate local source, so I had to remove/workaround this. Worth checking!

Helper I
Helper I

In my case after I reselect the gateway, the problem was solved. 

Regular Visitor

Thank you for your responses. Why does this code require a Gateway to be installed? Is there a way to allow the code to be refreshed without a gateway? I don't know if using the gateway is an option, as my computer is not always powered on.


I would like this to work without a gateway. I have a separate query that uses an excel file from sharepoint to create a report. This query refreshes automatically with some Sharepoint magic. Then, when I added the query above to the original query to get the time, it wouldn't let me automatically refresh with the Sharepoint magic. Does that make sense?


So is there a way to have the two queries together so that they both refresh automatically? 



Hi @Bezos,


Actually, we don't need to configure the date gateway as your data source is online. 


For online source, it will refresh automatically.


However, if you want to set schedule refresh, you should set the data gateway. You could install your gateway in a server always online.


Best Regards,


Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-piga-msft I'm facing a similar issue. Unable to figure out why this is greyed out. I have connected to other data soruces successfully like Google BigQuery and my reports refresh daily. But now I'm using MYSQL query through an ODBC connection and after publishig the report on Power BI serivce, it shows greyed out and I cant seem to refresh.


Can you help here? I'm seeking a solution without installing a gateway locally as my system would not be powered on always. And failing to understand why this is only hapening with this data source and not others?



I'm actually unable to refresh the entire data set. This is what happens when I try and manually refresh the data from the workbook -> refresh now:Capture.PNGThis was my original question, why am I unable to refresh this data set?



Resident Rockstar
Resident Rockstar

Hi @Bezos,


By my tests, if you install the Data gateway(personal mode) and edit the credential with Anonymous, then you could set up the schedule refresh.




Best  Regards,


Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Excellent!!!!! thanks a lot for your reccomendations  👍

So if I install the personal gateway, the report will refresh, but only if my laptop is powered on. So this is not a solution afterall 😞

hi, did you find the solution?

I'm facing the same problem. My data are located in my Sharepoint environement, and I don't want to use a gateway (Thank you IT guy)

How to refresh my reports?

No I couldn't find a solution 😞




Were you able to get it to work with the query I posted? Why doesn't this particular code work to automatically refresh??

Hi @Bezos 


any luck in this issue? I'm having the same issue now. seems like this is an old post and I was hoping

there is already a work around..



I had the same error.

My report already contained one data source (SQL) through on-premise gateway and one SharePoint online data source. Worked without a problem.
I added another SharePoint online data source and merged this result with the SQL data in Power Query. After that I could not enter credentials for SharePoint, I was requested to add it to the gateway which can not be done since there are no organizational authentication and windows authentication doesn't work for SharePoint online
I removed the merge in Power Query and instead added it to the data model and then it worked.

Can it have something to do with privacy levels?

Frequent Visitor

There is a checkbox on the gateway settings that says "Allow user's cloud data sources to refresh through this gateway cluster". I checked that and then the data source settings for the SharePoint source was enabled again on my dataset setting.

Not applicable

I faced the same problem, and to fix this, I open the Power Query in PBI Desktop, and refresh all the query previews and then save the PBI desktop file again. and then when I refresh the PBI dataset in PBI services online, the warning goes away.


Hope that works for you as well

Not applicable

@Bezos  The issue is that you have used Web.Contents in your source line and therefore need a gateway.  If you are using SharePoint online, you need to change your Source line in your M code to something compatable with "Connect Directly"

Not applicable

If its SharePoint Online, you wont need a gateway, but if its SharePoint on Premise you will.

Helpful resources

collabdays lisbon

CollabDays Lisbon - 26 November 2022

Sessions include practical, hands-on experience that will help you take the next step in your career and know-how.

Difinity Conference

Difinity Conference 2022

Difinity is the largest Microsoft Data, AI, Power BI, Power Platform and Business Applications Conference in New Zealand.

European Share Point Conference

European Share Point Conference

This conference returns live and in-person in Copenhagen this 28 November-01 December with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Microsoft 365 Conference â__ December 6-8, 2022

Microsoft 365 Conference - 06-08 December

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Top Solution Authors