cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
samira Frequent Visitor
Frequent Visitor

Data Source Credential error upon using OAuth 2.0 to Refresh Kusto data

I made a powerbi report that I published to the service with success. 

To schedule refresh on Power BI service, I use OAuth2. When I enter my credentials, I get two errors:

 1.  You need to use SSL (HTTPS) when you use OAuth 2.0 authentication.         

 2.  Message: AADSTS90015: Requested query string is too long. 

 

Everything works great on Power BI Desktop. 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Data Source Credential error upon using OAuth 2.0 to Refresh Kusto data

Hi @samira,

 

Did you notice that I used a Kusto connector while you used a Web connector? Please try again with the Kusto connector. Please refer to the snapshot below.

Data-Source-Credential-error-upon-using-OAuth-2-0-to-Refresh-Kusto-data

 

Best Regards,
Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
4 REPLIES 4
Community Support Team
Community Support Team

Re: Data Source Credential error upon using OAuth 2.0 to Refresh Kusto data

Hi @samira,

 

I set it up and refreshed successfully. I would suggest you make changes to your data source as the error message guided. The connection string could be like this: https://kkkkkkk.kusto.kkkkkk.net:443. The point is 443, which means the connection is encrypted.

Data-Source-Credential-error-upon-using-OAuth-2-0-to-Refresh-Kusto-data

 

Best Regards,
Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
samira Frequent Visitor
Frequent Visitor

Re: Data Source Credential error upon using OAuth 2.0 to Refresh Kusto data

DATAREFRESH.PNG

 

what type of changes should I make? I don't really understand your recommendation.

this is my connection string : https://kkkkkkk.kusto.kkkkkk.net:443/v1/rest/query?db/kkkkkkkkkkk&csl=.show version.OATH-PBI.PNG

 

 

This is the error I get when i try to edit credentials. 

Community Support Team
Community Support Team

Re: Data Source Credential error upon using OAuth 2.0 to Refresh Kusto data

Hi @samira,

 

Did you notice that I used a Kusto connector while you used a Web connector? Please try again with the Kusto connector. Please refer to the snapshot below.

Data-Source-Credential-error-upon-using-OAuth-2-0-to-Refresh-Kusto-data

 

Best Regards,
Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Community Support Team
Community Support Team

Re: Data Source Credential error upon using OAuth 2.0 to Refresh Kusto data

Hi @samira,

 

Could you please mark the proper answers as solutions?

 

Best Regards,

Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.