cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
csimon Frequent Visitor
Frequent Visitor

Dashboard tiles not rendering

I have created a Power BI group and uploaded reports from pbix. files to this group and created a dashboard. I am the administrator for this group. I have also created a content pack which includes the dashboard, reports, and datasets. I have given users permission to this content pack. When a user uses 'Get Data' and uploads this content pack to their 'My Workspace' the dashboard tiles will not render properly. they just see an empty tile showing only the Power BI icon. They can click on a tile and they are taken to the report as usual and the report renders fine. I have tried adding users to the group as both members and admins and removing them completely from the group with no changes. I can pull the dashboard into my 'My Workspace' and everything works as expected. Any help would be appreciated.

16 REPLIES 16
Super User
Super User

Re: Dashboard tiles not rendering

@csimon i am unable to reproduce your issue. when you say 'empty tile showing power bi icon', do you mean power bi icon before it loads tiles? if yes then it might just be taking long to render visuals. i would say wait a little longer and check, refresh power bi site and check back again.

 

Moderator v-yuezhe-msft
Moderator

Re: Dashboard tiles not rendering

Hi csimon,

I test the scenario as yours and everything works as expected. Could you please post a screenshot about the dashboard tiles in question? And how about re-pinning reports to your dashboard and recreating the content pack?


Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
csimon Frequent Visitor
Frequent Visitor

Re: Dashboard tiles not rendering

The screenshot below is from the mobile app, but the results are the same in the service.  What is strange is that i have given permissions to one of the users who is experiencing this issue and the dashboard renders fine.  Everything is set up the same way with the group and the content pack.  Several of the reports use the same SSAS Tabular models as the dashboard that is giving the issues.PowerBI.PNG

Moderator v-yuezhe-msft
Moderator

Re: Dashboard tiles not rendering

Hi csimon,

I connect to SSAS Tabular models via live query from Power BI service and then test your scenario, everything works well. Based on your description, users can be taken to the report after clicking the dashboard tile.

I suspect that the issue is related to web browser. Please recommend the user use different web browser such as Chrome and Firefox, then check if dahboard tiles render properly.

Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
csimon Frequent Visitor
Frequent Visitor

Re: Dashboard tiles not rendering

The user I am working with uses Firefox.  He also has the same results using Chrome, and on the mobile app on his iphone.

 

Thank you

csimon Frequent Visitor
Frequent Visitor

Re: Dashboard tiles not rendering

I have now found that if i pin a live page to a dashboard it renders with no issue. 

csimon Frequent Visitor
Frequent Visitor

Re: Dashboard tiles not rendering

I have also found that if my user makes a copy of a report that is used in the dashboard(s) that are not rendering and then creates a new dashboard everything works as expected.

Vicky_Song Established Member
Established Member

Re: Dashboard tiles not rendering

@csimon, what kind of tiles included in the Dashboard in your Content Pack? Reproducing your issue on would be quite helpful to figure out the root cause. 

csimon Frequent Visitor
Frequent Visitor

Re: Dashboard tiles not rendering

I am using cards, multi-row cards, stacked and clustered bar and column graphs.