cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper III
Helper III

Dashboard filters not working

I have just published a report which has a matrix and a couple of charts. I have filters for year and quarter, which when used in the desktop version filter all of the data (matrix and charts) as expected.

 

Now the report is published, I have created a dashboard  - a direct copy of the report page. However, when using the filters on the dashboard only the charts are filtered when various filters selected. The matrix doesn't update at all for some reason? I have also noticed that when viewing the data in the report online the filters are the same, only working for the charts not the matrix??

 

Is thre some setting on the matrix that I need to update? The matrix i am using is the matrix preview.

 

TIA

H

6 REPLIES 6
Power Participant
Power Participant

@Back2Basics You mean to say you have pinned live report page to Dashboard? If yes, might be preview version of table/matrix be facing issues though I haven't check. You can report the same to community blog under issues section if this continue to exists. 

Also another thing which controls interations are edit interactions options which should be enable to filter. Hope this works !

 

 

@ashishrj yes it is a preview matrix that I'm using.

 

how do I check if the edit intereactions things is working or in place?

@Back2Basics Check this out. First select any visual and then find this option activated. Hope this helps !

editinteractions.PNG

Thanks for this, I didn't realise you could do that - so that is really useful... but unfortunately in this case the interactions were all in place. Weird one

@Back2Basics,

 

I have tested it on my local environment, we cannot reproduce this issue. Preview Matrix visual works fine in a dashboar when pin a live page to your dashboard. In your scenario, could you please share you PBIX file with some sample data, so that I can try to reproduce this issue and make further analysis.

 

Regards,

Charlie Liao

I have since realsied that the matrix table does pdate, but for some reason you need to click on it for it to actually display the update. However, it does seem to crash sometimes when navigating through the drill down and back up. Not sure how to 'fix' it but atleast I can get it to work to some degree.

Helpful resources

Announcements
secondImage

Happy New Year from Power BI

This is a must watch for a message from Power BI!

December Update

Check it Out!

Click here to read more about the December 2020 Updates!

Community Blog

Check it Out!

Click here to read the latest blog and learn more about contributing to the Power BI blog!

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Mark your calendars and join us for our next Power BI Dev Camp!.

Top Solution Authors