cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dmercier
Frequent Visitor

Dashboard Pinned Report - Invalid report

I have pinned a visual from a report to a dashboard.  When I click the visual in the dashboard I get this message:  

"Invalid report
There is no dataset associated with this report. Please open the settings pane of the report and pick a dataset to bind the report."

 

I cannot find where to take this action?

 

Dave

2 ACCEPTED SOLUTIONS
selimovd
Community Champion
Community Champion

Hey @dmercier ,

 

did you try to remove the visual, refresh the browser and then pin it again?

This helps sometimes when there are problems with the tiles.

 

If you need any help please let me know.
If I answered your question I would be happy if you could mark my post as a solution ✔️ and give it a thumbs up 👍
 
Best regards
Denis
 

View solution in original post

v-robertq-msft
Community Support
Community Support

Hi, @dmercier 

According to your error message, I think the error happens because the dataset that links to your report is invalid or deleted. You should go to the report setting->view lineage to find the datasets that linked to the report and check if they are invalid or deleted.

v-robertq-msft_0-1617699723834.png

v-robertq-msft_1-1617699723841.png

 

If so,you should try to find out the reason of the dataset error or just republish the report again from desktop.

Here’s a case similar to this issue, you can also take a look:

https://community.powerbi.com/t5/Service/Error-asking-to-rebind-report-to-a-dataset/td-p/1099883

 

Best Regards,

Community Support Team _Robert Qin

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-robertq-msft
Community Support
Community Support

Hi, @dmercier 

According to your error message, I think the error happens because the dataset that links to your report is invalid or deleted. You should go to the report setting->view lineage to find the datasets that linked to the report and check if they are invalid or deleted.

v-robertq-msft_0-1617699723834.png

v-robertq-msft_1-1617699723841.png

 

If so,you should try to find out the reason of the dataset error or just republish the report again from desktop.

Here’s a case similar to this issue, you can also take a look:

https://community.powerbi.com/t5/Service/Error-asking-to-rebind-report-to-a-dataset/td-p/1099883

 

Best Regards,

Community Support Team _Robert Qin

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

selimovd
Community Champion
Community Champion

Hey @dmercier ,

 

did you try to remove the visual, refresh the browser and then pin it again?

This helps sometimes when there are problems with the tiles.

 

If you need any help please let me know.
If I answered your question I would be happy if you could mark my post as a solution ✔️ and give it a thumbs up 👍
 
Best regards
Denis
 

View solution in original post

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

July 2021 Update 768x460.png

Check it out!

Click here to read more about the July 2021 Updates