cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Brad2488
Regular Visitor

DM_GWPipeline_Gateway_MashupDataAccessError

Hi, we have a report completed in PowerBI desktop, and then published to the PowerBI web client. When we try and refresh, we get the following error when pointed at one of our SQL Server database servers. It works for one of our servers, and fails on the other.  Same databases, same permissions etc.

Data source error{"error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","pbi.error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","parameters":{},"details":[],"exceptionCulprit":1}}} Table: Query1.

 

 

 

 

 

1 ACCEPTED SOLUTION
Brad2488
Regular Visitor

Wasn't able to figure out the issue. Rebooting the server cleared it up.

View solution in original post

8 REPLIES 8
Brad2488
Regular Visitor

Wasn't able to figure out the issue. Rebooting the server cleared it up.

We had the same issue. The gateway couldn't reach one of the data source servers, so we restarted the data source server (not the one with the gateway on). Now it works fine.

Hello @Brad2488 

I am facing the same issue

You said your issue got fixed by rebooting the server. Did you mean the server where gateway is installed?

 

Regards

v-xuding-msft
Community Support
Community Support

Hi @Brad2488 ,

Firstly, please check if is caused by the firewall restriction. And then please try to launch on-premises data gateway application and ensure the HTTPS mode is off. 

5.PNG

 

If you used the Amazon provided Redshift ODBC driver, you could reference the solution below to have a try.

Redshift through on premise gateway fails due to ODBC driver 

 

If these all don't work for you, please create a support ticket to get the dedicated help.

Support Ticket.gif

Best Regards,
Xue Ding
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I don't think that HTTPS matters. I would try just updating and restarting the gateway first!

Hi @Brad2488 ,

Have you resolved the issue? If yes, kindly mark the helpful answer as a solution if you feel that makes sense. Welcome to share your own solution. More people will benefit from the thread.

 

 

Best Regards,
Xue Ding
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Couldn't figure out the issue, but rebooted the server, and that cleared it up.

Greg_Deckler
Super User
Super User

You could check the Issues forum here:

https://community.powerbi.com/t5/Issues/idb-p/Issues

And if it is not there, then you could post it.

If you have Pro account you could try to open a support ticket. If you have a Pro account it is free. Go to https://support.powerbi.com. Scroll down and click "CREATE SUPPORT TICKET".


@ me in replies or I'll lose your thread!!!
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
Learn Power BI 2nd Edition

Helpful resources

Announcements
August 2022 update 768x460.jpg

Check it Out!

Click here to learn more about the August 2022 updates!

August 1 episode 9_no_dates 768x460.jpg

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Top Solution Authors