cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BIfanatic Resolver I
Resolver I

Custom link to report not working (no permission)

Hi everyone,

 

Ever since this week I have encountered a problem when publishing a report to the Service. 

 

When I want to set a custom link from an existing dashboard to a newly published report, the text box becomes unclickable. Although there is a link to the report, the link is not active.

 

While existing reports do not seem to be having this problem, new reports seem to be influenced by some sort of bug.

 

Is this a known issue? If so, is there any work-around?

 

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
BIfanatic Resolver I
Resolver I

Re: Custom link to report not working (no permission)

Hi @v-yuezhe-msft,

 

I have found a workaround. When sharing a dashboard, some reports become unclickable. If you then pin the live page of the report to the dashboard and you refresh the dashboard, you see that the live page becomes visible and the tile with the custom link becomes clickable. Just delete the live page and the tile works.

 

In some way this seems to correct the indiscrepancies between the authorizations for the report and the dashboard.

 

Hopefully this helps.

View solution in original post

7 REPLIES 7
Microsoft
Microsoft

Re: Custom link to report not working (no permission)

@BIfanatic,

Do you add a textbox tile in the existing dashboard and add report link in the tile as below? If so, I am not able to reproduce your issue. Would you please share me your PBIX file via Private Message? I will test it in my environment.

1.JPG


Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
BIfanatic Resolver I
Resolver I

Re: Custom link to report not working (no permission)

Hello @v-yuezhe-msft,

 

Unfortunately I am not allowed to share the file, however I do believe that the problem is not in the .pbix file.

 

When I upload report X and I add a textbox tile in dashboard Y, which already existed, I then link from this tile to the report (sorry, it is in Dutch):

Example report sharing.JPG

 

 

The tile however, becomes unclickable for those with whom the dashboard has been shared. For me, as owner of the dashboard, it works fine.

Microsoft
Microsoft

Re: Custom link to report not working (no permission)

@BIfanatic,

I can reproduce your issue. I will report this issue internally and post back once I get updates.

Regards,

Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
BIfanatic Resolver I
Resolver I

Re: Custom link to report not working (no permission)

Hi @v-yuezhe-msft,

 

I have found a workaround. When sharing a dashboard, some reports become unclickable. If you then pin the live page of the report to the dashboard and you refresh the dashboard, you see that the live page becomes visible and the tile with the custom link becomes clickable. Just delete the live page and the tile works.

 

In some way this seems to correct the indiscrepancies between the authorizations for the report and the dashboard.

 

Hopefully this helps.

View solution in original post

BIfanatic Resolver I
Resolver I

Re: Custom link to report not working (no permission)

Hello @v-yuezhe-msft,

 

Might this issue be related to the new report-sharing feature?

https://powerbi.microsoft.com/en-us/blog/share-reports-with-your-teams-and-partners/

Microsoft
Microsoft

Re: Custom link to report not working (no permission)

@BIfanatic

I test the issue again today and found that only when the users have access to the underlying report, they can view the report via the custom link in the dashboard. And the issue is not related to that if the report is published recently.

For your existing report, have  you shared the report to users via other methods? For example, share other dashboard that contains the existing report. You can provide the URLs of the existing report and newly published report to your users, and check if they have permissions on the reports.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
BIfanatic Resolver I
Resolver I

Re: Custom link to report not working (no permission)

@v-yuezhe-msft,

 

Before the implementation of report sharing, it was a bit harder to manage all the permissions. Hopefully it will work better now that we can share reports as well.

 

If I encounter another bug, I will report it. For now, I consider this solved.

Helpful resources

Announcements
Announcing the New Spanish Forum

Announcing the New Spanish Forum

Do you need help in Spanish? Check out our new Spanish community section.

MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

‘Better Together’ Integration Forum Launch

‘Better Together’ Integration Forum Launch

We've launched a how-to forum where you can learn about how Power BI integrates with other Power Platform products.