cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jameslo30
Advocate III
Advocate III

Custom Visuals not working?

Has anyone's custom visuals stopped working / not displaying properly today?

1 ACCEPTED SOLUTION

Update:

 

I had to re-do all of my reports from scratch. Custom visuals now work.

 

I tried to update the Custom Visuals via PowerBI Desktop with a newer version, but this did not resolve the issue. I had to create a blank report and start again.

 

Ensure you download the latest version of your custom visual. 

View solution in original post

23 REPLIES 23
GarethDolphin
Advocate I
Advocate I

I've had this same problem today.

 

For months I've bene using the custom DialGauge visual and it has been working fine.

But as of tonight every single report that I open in Power BI Desktop that contains it now displays a blank tile where it should be, no data fieldwells or formatting options when the blank tile is selected, and no visualization icon on the right-hand side. This is the same in 7 or 8 reports that have worked for months with this custom visual.

Other custom visualizations in the same reports, such as the Globe Map, all continue to work properly.

It's just the Dial Guage from Power BI's visuals gallery is broken.

If I start a new/blank report and try to import it, Power BI Desktop (the latest public release) says its imported successfully, yet the icon for the visualization is not added to those that are available in the report.

If I download the sample .pbix containing it from the Power BI visual gallery the tile is also blank (and no icon):
https://app.powerbi.com/visuals/show/DialGauge1450749964276

Has anybody else experienced this?

I make heavy use of the custom KPI gauge so a qucik solution would be greatly appreciated.

I even moved forward a release of Power BI Desktop in the hope it would solve the problem.

Now all of my Power BI service tiles that were displaying this visualization are blank.

Help!




I've had the exact same experience and I'm trying to move my dashboards to production.  Very frustrating.

gooranga1
Impactful Individual
Impactful Individual

Ours are also dead this morning on the day it was being demo'd to our board of directors!

 

We can't Pin Live Page either even if the page has no custom visuals. Pinning individual visualisations works okay though.

 

 

Anonymous
Not applicable

Hi,

 

I'm facing the same issue as you all (custom visualization and live pages not working).

As gooranga1, we were planning to demo a dashboard today ... bad customer feedback from the directors!

 

Synoptic Panel seemed to work again though, but the other custom visualization are still not working.

I just wanted to chime in as I'm having exactly the same issue as of this morning.

I hope whatever they're doing also allows custom visuals to be used in Content Packs!

Not working for us either.  Just get the grey Power BI logo.

Not working for us either

Tishchenko
Continued Contributor
Continued Contributor

this is official demo from powerbi.microsoft.com! (custom visual  "Chiclet Slicer" used)

https://powerbi.microsoft.com/ru-ru/departments/operations/#1

This is a today PowerBI weekly update from 13.0.1100.519 to 13.0.1100.556.

Guys from PB team use customers in beta-tester role?

 

2.png

Update on the Dial Gauges : 

about 2 hours ago they started working again. Smiley Happy

Update:

 

I had to re-do all of my reports from scratch. Custom visuals now work.

 

I tried to update the Custom Visuals via PowerBI Desktop with a newer version, but this did not resolve the issue. I had to create a blank report and start again.

 

Ensure you download the latest version of your custom visual. 

sebbayard
Helper I
Helper I

Yesterday the dial gauge stopped working and will not display in dahsboards nor reports (in PowerBI online).

I've tried to re-install the visual, and that won't work either.

 

It seems to be working fine in PowerBI Desktop btw.

 

Cheers

Ben

It appears to be related to Row Securty for me  (regardless of who is assigned row security) 

 

As soon as I apply a RLS role no-one can access their dashboards

 

I had remove RLS (only testing with RLS so no big deal for me at the mo) and un-share and re-share my dashboards for it to start working again

Custom visuals still arn't working. I've opened a ticket last week and still not had a reply.


Everytime I open a ticket with Power BI it takes MONTHS for someone to take it and reply. DIABOLICAL. 

i have the same problem today!

 

Pfff really annoying.

Please let me know if you find anything.

None of the custom visuals used on our reports are working.

 

This is really annoying.

None of my visuals are working for users other than me. None are custom visuals

 

 

They get this displayed  (while I can still see them in my Workspace)

 

TILES ISSUE.PNG

cmn
Helper III
Helper III

Yes!  Ours have stopped working last night (around 14 hours ago).  We use 2 types of custom visuals - the Cards With State by SQL BI, and the Linear Gauge.  The cards with state we use as is (out of the box), but we have had to customise the Linear Gauge because it was quite buggy.  Last night, the  Cards With State was OK, but the dial gauge would not render on web or mobile.

 

We also noticed performance issues - sometimes the dashboard would not display at all on mobile (loading spinner displays forever), and we also noticed that the service just seemed slower.

 

Now, (the next morning), the custom visuals are working on the web site (although very slow to render), but the mobile app does not display any of our dashboards at all (loading spinner only).

 

 

Which custom visual are using?

 

Is anyone else experincing any problems?

Ah at least it isn't us then!!

We are also using the Cards by State, and also using the "Text Scroll" visual. Still not working today (08.04.16 @ 08:37)

 

The amount of problems with have with PowerBI is getting unreal. I am seriously concidering dropping it for something else. PowerBI in the cloud is just too unstable and unpredictable. Issues like this crop up and there are no details in the support section of this site indicating a problem / nor on the Office 365 Healthboard.

 

The visuals work fine in PowerBI Desktop. So I know they are working 100%. It's just the online view that's screwed.

 

 

 

 

 

I having the same issues works completely fine in Desktop but online Power BI it is not workign at all.  

Christopher E. Ortega, MBA
Manager, FP&A

Helpful resources

Announcements
November 2022 Update

Check it Out!

Click here to read more about the November 2022 updates!

Power BI Dev Camp Session 27

Ted's Dev Camp

This session walks through creating a new Azure AD B2C tenant and configuring it with user flows and custom policies.

Health and Life Sciences Power BI User Group

Health and Life Sciences Power BI User Group

Power BI specialists at Microsoft have created a community user group where customers in the provider, payor, pharma, health solutions, and life science industries can collaborate.

Top Solution Authors
Top Kudoed Authors