cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
smsalah Frequent Visitor
Frequent Visitor

Couldn't load the schema for the database model

I have a trial Pro Account. I am creating reports using Microsoft SSAS (SQL 2016) and When I publish a report from Power BI Desktop to PowerBI Portal, Everything is Ok. But when I access the report on PowerBI Portal Account. I get the following message " there was a data source access error. Please contact the gateway administrator" and also this message 

Couldn't load the schema for the database model
Couldn't load the model schema associated with this report. Make sure you have a connection to the server, and try again.
Please try again later or contact support. If you contact support, please provide these details.
Here are the technical details
Activity ID7f78279b-27a8-c4db-a67f-14c1a0cc97e4
Request ID5d3d3186-7977-19fa-2bfb-8ca555ba6d02
Correlation ID9556844c-4e35-f280-0765-f473ce5737a8
TimeMon May 21 2018 10:36:02 GMT-0400 (Eastern Daylight Time)
Version13.0.5314.162
 
I have checked everything from effective user name to all the posts but the problem is not resolved. Is it because I have trial Pro Account. If it is so why does not Power BI warns me about it ?.
 
Regards,
Salah
 
5 REPLIES 5
Super User
Super User

Re: Couldn't load the schema for the database model

@smsalah Do you have a gateway set up? I assume you are using a live connection in the Desktop, if that is the case, you need a gateway to communicate with the on-premises SSAS instance.

Near SE WI? Join our PUG Milwaukee Brew City PUG
smsalah Frequent Visitor
Frequent Visitor

Re: Couldn't load the schema for the database model

Thanks for your reply. I have setup the gatway properly and set all the required values.I can share the gateway log if it will help understand the problem. thanks

Super User
Super User

Re: Couldn't load the schema for the database model

@smsalah The free trial should only limit sharing and collaboration from my understanding. What is the error at the dataset? Does it recognize the gateway connection you've made? Did you assign the user as a valid user of the datasource on the gateway?

Near SE WI? Join our PUG Milwaukee Brew City PUG
smsalah Frequent Visitor
Frequent Visitor

Re: Couldn't load the schema for the database model

Dear Seth,

you are right I guest. the trial should not have to do with this. Well I do not know what the error at the dataset. It does recognize the gateway connection, when I refersh, it does not complain. Funny thing is the reprts show the measure and dimension tables

and fields in the portal but data problem.pngData Not loaded

Super User
Super User

Re: Couldn't load the schema for the database model

@smsalah One thing I've found helpful is to try to intitiate the error, then note the time and look in the gateway logs to see if you can see a more specific error.

Near SE WI? Join our PUG Milwaukee Brew City PUG