cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
djohnson Regular Visitor
Regular Visitor

Couldn't load the schema for the database model

Anyone else experiencing this bit of PowerBI "classyness" today?

 

Couldn't load the schema for the database model
 
We couldn't retrieve the data model for this report. Please try again later.
Please try again later or contact support. If you contact support, please provide these details.

 

Activity IDbd8e8bf9-2d7e-4397-9ad9-b6a68fe80b50
TimeThu Jun 30 2016 11:00:43 GMT-0400 (Eastern Daylight Time)
Correlation IDca5ee8aa-ffe7-3ff6-52e1-85a1e3a733d2
Version13.0.1500.307

 

12 REPLIES 12
Moderator v-yuezhe-msft
Moderator

Re: Couldn't load the schema for the database model

Hi @djohnson,

Could you please describe more details about your scenario? We need to know that what is your data source and the operation you take in Power BI when the error occurs.

Based on the above error message, please verify that if your data source is removed, renamed, moved, offline. Make sure that the source is still in the original location and you have permission to access it.  There is also an article about troubleshooting the similar error for your reference.

Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
aineslider Frequent Visitor
Frequent Visitor

Re: Couldn't load the schema for the database model

I have the same problem, my scenario is:

 

SQL 2014 Enterprise with Analysis Services MD.

ADW2012 databse DW and cubes.

On-Premises data gateway installed and running.

gateway connect in the cloud (website) and running.

The effective user is administrator to Analysis Services.

 

I build simple chart with powerBI desktop wirh live connection to SQL 2014 and working well, on the bottom right shows live connection: Connected

 

The problem is when I share the report to the cloud, always show this error.

 

We couldn't retrieve the data model for this report

 

No se puede cargar el esquema de modelo asociado a este informe. Asegúrese de disponer de conexión al servidor e inténtelo de nuevo.
Vuelva a intentarlo más tarde o póngase en contacto con el soporte técnico. Proporcione estos detalles si se pone en contacto con ellos.

 

Identificador de actividadd75b418f-34be-47c0-a855-39b28f1e7e9b
HoraFri Jul 22 2016 12:51:17 GMT+0200 (Hora de verano romance)
Id. de correlación35b545f4-0bbf-ec0f-d6a0-f4f500946869
Versión13.0.1500.472

 

 

andrewnzinuk Frequent Visitor
Frequent Visitor

Re: Couldn't load the schema for the database model

Same problem - come in today and the service account was locked for instance of analysis services and get messages about :

 

Couldn't load the schema for the database model
 
You don't have permission to view this report because the owner has set row-level security (RLS) on the data model. Please contact the report owner. Please try again later or contact support. If you contact support, please provide these details.
 
No RLS has been enabled. What is going on!!!!
 
Cheers
 
Andrew
aineslider Frequent Visitor
Frequent Visitor

Re: Couldn't load the schema for the database model

sidwayne Frequent Visitor
Frequent Visitor

Re: Couldn't load the schema for the database model

Yes, this is the solution. The UPN account in your local AD.

Administrator SunilGudipati
Administrator

Re: Couldn't load the schema for the database model

Hi,

I am also getting same kind of issue. Please see the following details. Please help on this.

 

We couldn't retrieve the data model for this report. Please try again later.
Please try again later or contact support. If you contact support, please provide these details.

 

Activity ID94d70ccc-5ba8-4165-bb8a-d05366c0bef9
Request ID18ed59fb-3810-ab17-f870-57f43700336a
Correlation ID51f1c66c-5211-6136-e32f-441927f8cb11
TimeThu Jun 29 2017 19:31:55 GMT+0000 (Coordinated Universal Time)
Version13.0.1781.234

 

Thank you

Sunil

DancesWithBI Frequent Visitor
Frequent Visitor

Re: Couldn't load the schema for the database model

Hi,

 

I have been getting a similar error. I am running an instance of SSAS Tabular on my local machine and have tried to set up both a personal and an enterprise data gateway to it, but no matter what I do my Power Bi report fails. I have tried mapping the UPN as Adam describes but it still does not work. Any guidance anyone could provide would be much appreciated.

 

Thanks,

Dave

arathore Frequent Visitor
Frequent Visitor

Re: Couldn't load the schema for the database model

I have the exact same issue. Changing UPN does not work.  I am the owner of power bi gateway and  this report. I also have access to the dataset from Power BI desktop. Is this an issue with RLS in SSAS tabular model ?

RobertP Frequent Visitor
Frequent Visitor

Re: Couldn't load the schema for the database model