cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
yamini Frequent Visitor
Frequent Visitor

Couldn't load the model schema - Publishing report using Azure AnalysisServices with live connection

When I am trying to publish a Report connecting to Azure analysis services with live connection as a datasource.I see report published as successful but I am seeing the following error  "Couldn't load the model schema associated with this report. Make sure you have a connection to the server, and try again" when I am trying to open the report or dataset published in cloud.

 

Please help me to resolve this issue.

 

Thanks

3 REPLIES 3
Super User III
Super User III

Re: Couldn't load the model schema - Publishing report using Azure AnalysisServices with live connec

@yamini Did you create a data source on an (Enterprise) On Premises Gateway to the SSAS model? Did you assign your user as a valid user to that datasource? Do the names in your connection in the report match that of the datasource? All these need to be done in order to have the data sources sync.

In addition, you need to ensure that you email you log into Power BI Service with, matches your UPN (User Principle Name) of your domain credentials, because with a live connection Power BI is passing your creds back to authenticate against the SSAS server. (which you would also need at least read permissions to).


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG
yamini Frequent Visitor
Frequent Visitor

Re: Couldn't load the model schema - Publishing report using Azure AnalysisServices with live connec

Seth,

 

Thank you for replying !

 

My data source(Tabular model) is in cloud, so I assume On Premise Gateway is not required.I was able to publish the report in Import mode successfully and able to view the report in portal where as Live connection to Azure analysis services is erroring out.

Please help me if there is a way to get this issue resolved.

 

Thanks

 

 

Community Support Team
Community Support Team

Re: Couldn't load the model schema - Publishing report using Azure AnalysisServices with live connec

Hi @yamini

Do you connect to Azure Analysis Services in Power BI? If so, gateway is not required when your dataset only contains the Azure Analysis Services data source.
After you publish the PBIX file to Power BI Service, you will find that Power BI Service connects directly to your data source.

 

When you connect to SSAS which is installed in Azure VM and refresh this dataset, gateway is required.

Reference:

https://docs.microsoft.com/en-us/power-bi/service-gateway-enterprise-manage-ssas

 

Best Regards

Maggie

Helpful resources

Announcements
Meet the 2020 Season 1 Power BI Super Users!

Meet the 2020 Season 1 Power BI Super Users!

It’s the start of a new Super User season! Learn all about the new Super Users and brand-new tiered recognition system.

Super User Challenge: Can You Solve These?

Super User Challenge: Can You Solve These?

We're celebrating the start of the New Super User season with our first ever Super User 'Can You Solve These?' challenge.

Power BI Desktop Update - February 2020

Power BI Desktop Update - February 2020

We are super excited for our update this month, as we are releasing two of our top community requests!

Power Platform Online Conference

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

Top Solution Authors
Top Kudoed Authors