cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Miruthan Regular Visitor
Regular Visitor

Couldn't load the data for this visual - Working in Desktop but not in enbedded and powerbi service

Hi Experts,

 

I am using direct query from Azure DB, the visuals are working fine in PowerBI desktop, but couple of visual is broken in PowerBI service and embeeded with the below error. We have enabled RLS as we are using this feature.

 

Couldn't retrieve the data for this visual. Please try again later.
Please try again later or contact support. If you contact support, please provide these details.

Activity IDdb868c01-4618-041c-7773-6ecdc85b7bf4
Request ID35e3cffd-61f2-9d86-c7ad-4c2e2c6f06c3
Correlation IDf55e78a5-80dd-1766-06dd-e40be1e4cf44
TimeThu Apr 19 2018 15:34:54 GMT+0100 (GMT Summer Time)
Version13.0.4965.191
 
Not able to find the root casue too.
 
It would be really helpful if you share your thoughts.
1 ACCEPTED SOLUTION

Accepted Solutions
quintoncoish Frequent Visitor
Frequent Visitor

Re: Couldn't load the data for this visual - Working in Desktop but not in embedded and powerbi serv

I can confirm this has been resolved by Microsoft.  I'm not sure what the issue was or how they solved it but our powerbi embedded reports using directquery are now working again .  Hopefully it's working for everyone else as well Smiley Happy

12 REPLIES 12
quintoncoish Frequent Visitor
Frequent Visitor

Re: Couldn't load the data for this visual - Working in Desktop but not in embedded and powerbi serv

I'm experiencing the exact same issue using embedded with role-level-security.

 

The report works perfectly on the desktop but when embedded only some visuals are loading while others give an error.  It worked perfectly up until yesterday and we haven't made any changes to the reports or the way the embedded reports render within our application within the past few weeks.

 

One thing I noticed is that if I start to remove fields from the table that's giving the 'load error' then it loads without any errors.  If I put the fields I remove in another table they display correctly - so it doesn't look like it's an issue with any calculated formula fields.

 

Any suggestions for help would be great.

 

Thanks!

 

PBI Desktop: 2.57.5068.501 64-bit (April, 2018)

using DirectQuery Mode to Azure SQL

using Role Level Security

using embedded powerbi within our website

 

 

image.png

Miruthan Regular Visitor
Regular Visitor

Re: Couldn't load the data for this visual - Working in Desktop but not in embedded and powerbi serv

Exactly the same issue with us. I think it is a bug. It is blocked production deployment,powerbi team in tremendous pressure. MS must give some solution.

quintoncoish Frequent Visitor
Frequent Visitor

Re: Couldn't load the data for this visual - Working in Desktop but not in embedded and powerbi serv

I've oppened a support ticket with Microsoft - I'll post updates here once I hear back from them.

Highlighted
Miruthan Regular Visitor
Regular Visitor

Re: Couldn't load the data for this visual - Working in Desktop but not in embedded and powerbi serv

Great! , Waiting for your solution.

quintoncoish Frequent Visitor
Frequent Visitor

Re: Couldn't load the data for this visual - Working in Desktop but not in embedded and powerbi serv

Microsoft is working on a solution for the issue in this post and will be posting updates here: https://powerbi.microsoft.com/en-us/support/

 

"Some Power BI users may not see certain visuals when viewing reports using Direct Query. Engineers have found the issue and are working on deploying a fix. Next update @ 04/24/2018 10:00 PM UTC."

quintoncoish Frequent Visitor
Frequent Visitor

Re: Couldn't load the data for this visual - Working in Desktop but not in embedded and powerbi serv

I can confirm this has been resolved by Microsoft.  I'm not sure what the issue was or how they solved it but our powerbi embedded reports using directquery are now working again .  Hopefully it's working for everyone else as well Smiley Happy

Miruthan Regular Visitor
Regular Visitor

Re: Couldn't load the data for this visual - Working in Desktop but not in embedded and powerbi serv

@quintoncoishThank you!, it is working for me too.

jmccurdy Frequent Visitor
Frequent Visitor

Re: Couldn't load the data for this visual - Working in Desktop but not in enbedded and powerbi serv

Hi,

we are now having this issue again on Power BI Embedded. Are we aware how Microsfoft fixed it the last time

 

Kind Regards

 

John

jmccurdy Frequent Visitor
Frequent Visitor

Re: Couldn't load the data for this visual - Working in Desktop but not in enbedded and powerbi serv

Hi,

we are now having this issue again on Power BI Embedded. Are we aware how Microsfoft fixed it the last time

 

Kind Regards

 

John