cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Post Prodigy
Post Prodigy

Concatenate Labels option does nothing?

Using this option in the service, I don't get any change to take place.

 

I'm using the area chart.

 

Anyone else have this issue?

 

I have Year, then Month in a hierarchy... expanding out still shows 2016 04  not a box with 2016 then inside/above/whatever all the months.

41 REPLIES 41
Anonymous
Not applicable

Hi @OneWithQuestion and @sykr0n

The tests i carried out were on power bi desktop.  Latest April Version: 2.45.4704.442 64-bit (April 2017)

Have you tried to follow the steps in the exact order to produce the chart as I have provided in the scenarios that worked?

My tests were carried with a simple revenue column in a sales fact table; and month, quarter , year in a date dimension table.

I was able to reproduce the bug and also the work around - multiple times.

 

following steps produce bug:

I have found that whilst in "report" screen/tab, when you select a measure e.g. sales value before selecting any chart type, power bi automatically selects the "clustered column chart" and then when you select the fields for the "axis", e.g. the  month, quarter, year then when you go to formatting to switch off "concatenate label" under "x -axis" then nothing happens.  This is the steps that produce the bug.  

 

work around:

So do not do the above.  Instead First select the chart (e.g. clustered columns chart)  and then select your measure for the "value" field and the columns for the "axis" fields.  then when you go to formatting to switch off "concatenate label" under "x -axis"  - it works.  The order in which you create the chart is important to avoid the bug.

 

I hope I have left no confusion in the steps.  if you wish to call me then pm annd i will provide my number.

I cannot get concatenation to turn off - I followed your instructions exactly and it worked for two tests where I drilled into a column on a clustered column chart.  After this, it then reverted back to concatenation so the x axis titles are meaningless.  Even when this did work, it put the highest level label at the bottom of the chart and the 2nd level label as the x axis.  When I drilled into the 3rd level, it concatenated everything together in one giant run-on x axis label.  This is apparently a bug and it needs to get fixed.

 

(my x-axis concatenation label option is set to off and I set-up my chart in the order you outlined)

this feature ist still bugy! 😞 Tested with May 2017 release 2.46.4732

Advocate I
Advocate I

Hi guys! I also first struggled with this, but think I've managed to figure it out. You need to follow the process below to get your labels concatenated or un-concatenated. Step 1: Create a table and add your 'Date hierarchy' and 'Measure' Step 2: Turn your table into the chart you would like, i.e. line, bar or area chart (stacked or normal) Step 3: 'Expand all down one level in the hierarchy' until you've reached your desired hierarchy level Step 4: Under the Formatting Pane, open the X-Axis settings and change the 'Type' from 'Continuous' to 'Categorical' Step 5: Switch the 'Concatenate labels' slider to off And voila, you have a perfectly working Concatenate label option. The key here is to start with a table, add your variables, drill down, change to categorical and then only it works perfectly. Hope this helps. Have an awesome day!! Llewellyn Holtshausen Databear.com - Your Data, our story!
Advocate I
Advocate I

Hi guys! I also first struggled with this, but think I've managed to figure it out. You need to follow the process below to get your labels concatenated or un-concatenated. Step 1: Create a table and add your 'Date hierarchy' and 'Measure' Step 2: Turn your table into the chart you would like, i.e. line, bar or area chart (stacked or normal) Step 3: 'Expand all down one level in the hierarchy' until you've reached your desired hierarchy level Step 4: Under the Formatting Pane, open the X-Axis settings and change the 'Type' from 'Continuous' to 'Categorical' Step 5: Switch the 'Concatenate labels' slider to off And voila, you have a perfectly working Concatenate label option. The key here is to start with a table, add your variables, drill down, change to categorical and then only it works perfectly. Hope this helps. Have an awesome day!! Llewellyn Holtshausen Databear.com - Your Data, our Story

I might be going crazy here, but the options just dissapeared from some chart types in powerbi desktops latest update?

Still not working properly. My hierarchy has 7 levels and concatenation of drill-down labels makes the chart completely unusable.

I have tried this so many times and followed all the different sets of instructions in this thread but I just can't make it work with my data. I'm using a date table and I've tried with the date field, plus separate year and month fields. I've tried with different charts. I've tried everything suggested and I just can't get this to work. Essentially my visuals are meaningless if I can't format the date legend properly. Which means hours of wasted time trying to knit everything together. I'm using September 2017 version. I'd request an update if I thought this had been fixed. So frustrating. Smiley Sad

Frequent Visitor

Just wanted to check if there is anything by which I can fix this?

 

Killing my time for such a small thing, I am using Jan 18 edition. 

Frequent Visitor

still broken for me too

Helpful resources

Announcements
November Update

Check it Out!

Click here to read more about the November 2020 Updates!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

secondImage

Power Platform October Community Highlights

Check out the top community contributors across all of the communities

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors