cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vhinzu
Regular Visitor

Change gateway from personal to enterpise

Hello,

 

I'm in a scenario where we are migrating from Office 365 Power BI with the Data Management Gateway to Power BI Pro with Power BI Personal or Enterprise Gateway.

 

After installing the Personal Gateway, I figured out that the gateway is not restarted automatically after a reboot. As the hosted machine needs to reboot every day for cost purposes (it is a cloud hosted machine), the personal gateway is not fitting my needs.

 

So I'm trying to test the Enterprise gateway which seems to be a proper service, which starts automatically and so on...

So far so good, however I'm stuck to a stupid issue :in Power BI service, how do I switch from a Personal to an Enterpise Gateway? The Enterprise option is grayed out, even if my DataSource has been correctly set up and tested in the configuration Panel. I have tried disabling the Personal Gateway on my server, but the radio button is still grayed out.

 

2016-02-14 10_45_29-Clipboard.png

Any idea?

 

2 ACCEPTED SOLUTIONS
greggyb
Resident Rockstar
Resident Rockstar

The Personal Gateway supports scheduled refresh against on prem data sources. The Enterprise Gateway currently only supports DirectQuery against SQL products and SAP HANA, as well as live connections to SSAS.

View solution in original post

I had the same issue, i.e. both personal (PG) and enterprise gateway (EG) installed and configured correctly, yet the "Use an enterprise gateway" option is disabled when configuring the gateway connection for the dataset. Both the EG and the PG have the same setup. The caveat is that the data source configured for the enterprise gateway must be configured exactly as the PG or the option to switch to enterprise gateway will be disabled. In my case I have configured the PG to connect to the server using also the domain eg. servername.domain while the EG was configured to connect to just servername without having the domain specified. Once I created a new EG data source using servername.domain the option to switch to an enterprise gateway was enabled and I could switch from the PG to the EG for all my datasets.

 

Topic discussing this problem.

 

http://community.powerbi.com/t5/Integrations-with-Files-and/Moving-from-personal-gateway-to-the-ente...

 

Big thanks to dimazaid on the Power BI team. 

View solution in original post

8 REPLIES 8
greggyb
Resident Rockstar
Resident Rockstar

The Personal Gateway supports scheduled refresh against on prem data sources. The Enterprise Gateway currently only supports DirectQuery against SQL products and SAP HANA, as well as live connections to SSAS.

View solution in original post

leeg
Frequent Visitor

UDc2Zwv

 

I have the same problem and i didnt understand your answer,

in the Enterprise ducoment you can see that the it support not only direct query.

If I have Excel source and i want to do schedual refresh with the Enterprise it dosnt support?

Help Thanks

 

I've the same issue.

 

1. Installed a personal gateway in a PowerBI-Tenant

2. Deinstalled it on the related pc(, check that no process is runnung, cleaned the registry).

3. Installed an enterprise Gateway (connection test successful)

 

After that i wanted to switch the dataset in power bi online (app.powerbi.com) from using the personal gateway to using the enterprise gateway. But there is no chance to choose it or to deactivate the personal gateway and to use the enterprise gateway:

 

personal-gateway.jpg

 

 

 

 

 

 

 

 

 

 

 

 

 

 

So what is the missing step to kill the personal gateway? How to get rid from that personal gateway? I tried to delete the datasets, reports, dashboard and deployed it from my local power bi desktop - resulting in the same issue, personal gateway is still present.

 

Ideas...? I'm extremly nervous to get asked that from our customers...

 

Torsten

 

 

 

I had the same issue, i.e. both personal (PG) and enterprise gateway (EG) installed and configured correctly, yet the "Use an enterprise gateway" option is disabled when configuring the gateway connection for the dataset. Both the EG and the PG have the same setup. The caveat is that the data source configured for the enterprise gateway must be configured exactly as the PG or the option to switch to enterprise gateway will be disabled. In my case I have configured the PG to connect to the server using also the domain eg. servername.domain while the EG was configured to connect to just servername without having the domain specified. Once I created a new EG data source using servername.domain the option to switch to an enterprise gateway was enabled and I could switch from the PG to the EG for all my datasets.

 

Topic discussing this problem.

 

http://community.powerbi.com/t5/Integrations-with-Files-and/Moving-from-personal-gateway-to-the-ente...

 

Big thanks to dimazaid on the Power BI team. 

View solution in original post

I think this is not a proper solution, even if it helped you fixing the issue at your end. Because before reaching to this post, most of the people would already have deleted their personal data gateway considering the setting up Enterprise Gateway should be straight-forward as it seems. And its then difficult to remember whether you used FQDN or IP to connect to the SQL instance. 

 

There should be a fairly simple process than this for changing from Personal to Enterprise gateway. isn't it?

Nope.  Gave this my fully qualified domain name and it still didn't enable the radio button.

vhinzu
Regular Visitor

Thank you so much, I just tried it and at least I could use the enterprise gateway to schedule my refresh.

You made my day! 🙂

I have the same issue. Started with personal gateway and unistalled it from my "server" and installed the latest Pro Gateway.  If I go to my Power BI Web and click on my dataset and click "Refresh Now"  I get the error "Your Personal Gateway is offline or couldn't be reached."  

 

 

If i check the gateways by clicking the (Gear) in the top right fo the page and select the data source settings for my datasource assigned to the Pro gateway it shows "Connection Successful". 

 

If I go back to my Dataset and click the elipsis (...) and select Schedule Referesh the page comes up with the error

"Your Power BI Gateway - Personal is offline. To set refresh scheduling please be sure your Power BI Gateway - Personal is online."

 

Further down it shows 

Gateway Connections:

      Use your personal gateway (offline)

 

and  "use an enterprise gateway is greyed out/unavailable"

 

I expected it to forget that I ever had a personal gateway and just use the Pro version. Any thoughts?

 

Thanks.

 

 

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Get Ready for Power BI Dev Camp

Microsoft named a Leader in The Forrester Wave

Microsoft received the highest score of any vendor in both the strategy and current offering categories.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.