cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper V
Helper V

Change gateway from personal to enterpise (Folder)

Hello,

 

I have a data set that I created on my PC, it uses the personal gateway.

I have now installed the enterpise gateway on another PC, and I would like to update an existing data set and change it from the personal gateway to the enterpise one. however the option is greyed out.

 

I have added the data source to the manage gateway setings (it is a folder data source).

 

How do I now change it to use the enterpise  one instead of the personal one?

 

Below is a screen shots:]

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Champion
Community Champion

@MarkCBB In my experience it hasn't always worked out best in switching from personal to data gateway but follow below steps first and if it doesn't work out then follow step 2.

 

Step1

 

Add folder data source to the data gateway first. Remove personal gateway from your computer. That will cause existing report to stop working. Then check under dataset settings if you're getting option to select data gateway.

 

Step2

Remove personal gateway from your computer and service. Remove report from power bi service. Then add data source to your data-gateway in power bi service. Then publish your pbix file to pbi service and it will automatically start using data gateway (as personal gateway is not found and folder data source is added to your data gateway).

View solution in original post

3 REPLIES 3
Highlighted
Community Champion
Community Champion

@MarkCBB In my experience it hasn't always worked out best in switching from personal to data gateway but follow below steps first and if it doesn't work out then follow step 2.

 

Step1

 

Add folder data source to the data gateway first. Remove personal gateway from your computer. That will cause existing report to stop working. Then check under dataset settings if you're getting option to select data gateway.

 

Step2

Remove personal gateway from your computer and service. Remove report from power bi service. Then add data source to your data-gateway in power bi service. Then publish your pbix file to pbi service and it will automatically start using data gateway (as personal gateway is not found and folder data source is added to your data gateway).

View solution in original post

Highlighted
Community Support
Community Support

Hi @MarkCBB,

 

In your scenario, does the dataset "TALBORNE" only contain one data source? Please also make sure the folder path used in data gateway is the same as the one when you create report in Power BI Desktop.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

Hello @ankitpatira and @v-qiuyu-msft

 

Thank you for your help, I was able to sort it out, by following Step 1.

I also didnt have all the data souces listed in the EGW.

once I had that setup the process was simple and quick.

 

Thank you

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors