cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
anandsonar1
Frequent Visitor

Card Visual Blank After Refresh

Hello, I've created dashboard and published on Power BI Services, after refershing detasets in Power BI Services card visuals are getting blank. It is working fine in Power BI Desktop only I'm facing this issue in Power BI Services. I've checked all detatypes, updated power bi latest version and tried all possible tricks but still it is not getting resolve. 

 

Kindly advice how I could fix this issue. 

 

Thanks & Regards,

Anand

1 ACCEPTED SOLUTION
ribisht17
Super User
Super User

@anandsonar1 

 

Please check this post   Blank visuals in Service but not in Desktop - Microsoft Power BI Community

The issue is only this report or for others as well ()

Any access issue with Power BI service

 

Regards,

Ritesh

View solution in original post

7 REPLIES 7
otravers
Super User
Super User

Doublecheck that you don't have any unexpected filtering applying to your cards:

otravers_0-1656866897588.png

 

------------------------------------------------
1. How to get your question answered quickly - good questions get good answers!
2. Learning how to fish > being spoon-fed without active thinking.
3. Please accept as a solution posts that resolve your questions.
------------------------------------------------
More tips and guidance in my Power BI architecture and development blog

Hello @otravers, I've checked there are no any unexpected filter applied to cards. Do you have any other ideas?

Kindly advise!

Regards, 

Anand

Is this after a dataset refresh in the service, or does this happen also just after publishing from Power BI Desktop?

------------------------------------------------
1. How to get your question answered quickly - good questions get good answers!
2. Learning how to fish > being spoon-fed without active thinking.
3. Please accept as a solution posts that resolve your questions.
------------------------------------------------
More tips and guidance in my Power BI architecture and development blog

@otravers, Yes, this is after detaset refresh in power bi service. This is working fine even after refresh in power bi desktop. Also it working after publish in power bi service, but if I refersh detaset in power bi service, card visuals are getting blank.

Please suggest some solution. 

 

Thanks & Regards, 

Anand

 

 

 

ribisht17
Super User
Super User

@anandsonar1 

 

Please check this post   Blank visuals in Service but not in Desktop - Microsoft Power BI Community

The issue is only this report or for others as well ()

Any access issue with Power BI service

 

Regards,

Ritesh

Hello @ribisht17,

I'm only facing this issue with this report. 
I've checked post of blank visuals in service but not in desktop and tried steps. 
Do you have any other solutions to get this issue solve?

Kindly address!

Regards, 

Anand

anandsonar1
Frequent Visitor

Hi @otravers @Hariharan_R @Tutu_in_YYC ,

I've created dashboard and published on Power BI Services, after refershing detasets in Power BI Services card visuals are getting blank. It is working fine in Power BI Desktop only I'm facing this issue in Power BI Services. I've checked all detatypes, updated power bi latest version and tried all possible tricks but still it is not getting resolve. 

 

Before Refresh

anandsonar1_2-1656829669139.png

 

After Refresh

anandsonar1_1-1656829639971.png

 



Kindly advice how I could fix this issue. 

 

Thanks & Regards,

Anand



Helpful resources

Announcements
September Update

Check it Out!

Click here to learn more about the September 2022 updates!

Power BI Show episode 9

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power BI Dev Camp Session 26

New Date - Check it Out!

Mark your calendars and join us on Thursday, October 6 at 11a PDT for a great session with Ted Pattison!

Top Solution Authors
Top Kudoed Authors