cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
howardng Frequent Visitor
Frequent Visitor

Cannot get proper Security in Service

In Power BI Desktop, I set Roles for my dataset, and get right Role in Power BI Desktop.

However, after i publish the desktop to Power BI Service, then i go to Security > Test as Role, it shows nothing for all Role, except Admin role.

 

Could anyone help?

 

Thanks!

3 REPLIES 3
Highlighted
Community Support Team
Community Support Team

Re: Cannot get proper Security in Service

Hi @howardng ,

Based on my test, it could work on my side, how could you set your rules for different roles? And if you have set with username function, it will not show in Test as role:

In Desktop:

1.PNG

 

In service(Test as role):

1.PNG

Also you could refer to below limitations:

https://docs.microsoft.com/en-us/power-bi/service-admin-rls#limitations

 

Regards,

Daniel He

 

Community Support Team _ Daniel He
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Community Support Team
Community Support Team

Re: Cannot get proper Security in Service

Hi @howardng ,

Could you please tell me if your problem has been solved? If it is, could you please mark the helpful replies as Answered to close this topic?

 

Regards,

Daniel He

Community Support Team _ Daniel He
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
howardng Frequent Visitor
Frequent Visitor

Re: Cannot get proper Security in Service

It is back to normal for few days, however, it cannot get proper RLS suddenly, so my teammates at Taiwan report it as an issue.

 

I think one people from Microsoft follow up with her. He suggested a solution, but the solution is not work.