cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tlanza
Advocate I
Advocate I

Cannot add a dataflow to a gateway

I created a dataflow using a blank query and I was able to run it showing the data, and save it correctly. It's important to note that I select my on-prem gateway at this creation step. However, when I try to refresh, it fails and says I need to add credentials. "Error: Data source credentials are missing or invalid. Please update the credentials for Web in dataflow settings and try again".

 

When I go to the dataflow settings, I'm unable to access the gateway and the data source credentials as they are greyed out (see pic below).  When I go in and edit the dataflow, the gateway selection changes back to "none". Does anyone have any suggestions? All of my other dataflows that are using this same source are working just fine.

 

Thank you.

 

Annotation 2019-08-28 090918.png

3 REPLIES 3
dax
Community Support
Community Support

Hi tlanza,

I test this in my environment, I use below query in blank query(I choose gateway before)

let
    Source = Sql.Databases("server\instance"),
    newsql = Source{[Name="newsql"]}[Data],
    dbo_sorttime = newsql{[Schema="dbo",Item="sorttime"]}[Data]
in
    dbo_sorttime

It will show me this option when I click "Next"

288.PNG

Then after I type credential and finish this, the dataflow works well  in my environment. You could try to set this in applied steps(edit queries->source) in your dataflow to see whether it works or not.

In addition, which type datasoure did you used in dataflow, could you please inform me in details?

Best Regards,
Zoe Zhi

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Hi Zoe Zhi,

I assume I would have to add that test sql  database to my gateway as a connection right? 

For my dataflow, I'm not trying to connect to a sql database. I'm trying to use a Web connection to make an API call to my system. I typically do all of my configurations to my data in Power BI desktop > copy the M code from the query > paste it as a blank query in the dataflow creation on the web. This has worked perfectly for me in the past with no issues. Now, over the past few weeks I've been running into these issues that prevent me from creating or adding to my existing dataflows. The dataflows I created months ago still work fine but I'm unable to make new ones. I should also add that only new dataflows I create do not allow me to edit the gateway information for them. All of the existing dataflows allow me to change the gateway information.

 

I'm hoping someone has a fix or this is a known issue becuase I shouldn't have to backdoor basic functionality.

I experience the exact same issue. In all newly created dataflows I am not longer able to configure the gateway credentials. 
Previously built dataflows don't have this problem and work perfectly. The workaround described by Zoe Zi doesn't'work for me, because I use custom scripts that retrieve a dynamic logon token to connect to my data source. 

I've'also created a support ticket for this problem. Microsoft, please fix this a.s.a.p.!

Helpful resources

Announcements
August 2022 update 768x460.jpg

Check it Out!

Click here to learn more about the August 2022 updates!

August 1 episode 9_no_dates 768x460.jpg

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Top Solution Authors