cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
drwillparry
Advocate I
Advocate I

Can't display the visual once dashboard is shared

I have a report I uploaded to the Power BI Service, which I then shared with people outside of my organisation. When I view the reports online, everything works fine, but when the people I shared it with try to access it, they get a load of tiles like the attached images, and nothing works.

 

Anyone know why this is? I created a dummy account to investigate, and an example error message is attached as well.

 

All the best,

Will

 

Capture.GIFCapture1.GIF

1 ACCEPTED SOLUTION
ankitpatira
Community Champion
Community Champion

@drwillparry error message isn't very clear expect it says something is wrong. You could try basic points to troubleshoot it.

Try sharing it with internal users and check if they can see everything.

I have come across this error few times when it works fine just after doing browser refresh.

Also check that RLS isn't enabled on the dataset.

You can also use send a frown option or create a support ticket with MS for them to look at.

View solution in original post

3 REPLIES 3

@drwillparry Other things to include: Depending on data source, the end users may need read access. I believe this could be achived via the UPN mapping.. haven't tested that though.

And the more likely. Either one of Ankit's suggestions or you need to make sure that if you are using any Pro features that the end users also have a Pro license.


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG
ankitpatira
Community Champion
Community Champion

@drwillparry error message isn't very clear expect it says something is wrong. You could try basic points to troubleshoot it.

Try sharing it with internal users and check if they can see everything.

I have come across this error few times when it works fine just after doing browser refresh.

Also check that RLS isn't enabled on the dataset.

You can also use send a frown option or create a support ticket with MS for them to look at.

View solution in original post

Thanks Ankit!

Somehow, I had managed to create Admin and User Roles in the Row Level Security, with zero group members. I deleted these roles and the shared dashboard now works as intended!

 

Many thanks,

Will

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Get Ready for Power BI Dev Camp

Microsoft named a Leader in The Forrester Wave

Microsoft received the highest score of any vendor in both the strategy and current offering categories.

Get Ready for Power BI Dev Camp

Power BI Dev Camp - September 30th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.