Reply
Frequent Visitor
Posts: 6
Registered: ‎02-24-2016
Accepted Solution

Can't Display the Visual

I have a Power BI Desktop model uploaded to Power BI (app.powerbi.com) using a Pro account, all latest versions as of May 4, 2016. The reports in Power BI worked fine for 1-2 weeks; however recently, none of the visuals are showing up. The only part showing up are the tables of data. To clarify, the visuals work fine in Power BI Desktop, but don't display in app.powerbi.com.

 

The file contains a mix of standard and custom visuals, the custom being the latest Attribute Slicer v0.10.0. I've tried switching to all standard visuals but still get the same error. Below is an excerpt of the error:

 

--------------------------------------------------------------------------------------------------------------------------------------

Couldn't load the data for this visual
Couldn't retrieve the data for this visual. Please try again later.
Please try again later or contact support and provide the following details to help resolve your issue faster.
Version 13.0.1100.480

--------------------------------------------------------------------------------------------------------------------------------------

 

Even re-uploading the Power BI desktop files that used to work fine in app.powerbi.com produce the same error.

 

Any ideas what may be causing this?


Accepted Solutions
Frequent Visitor
Posts: 6
Registered: ‎02-24-2016

Re: Can't Display the Visual

After diving a bit deeper, I discovered the issue only affected some of my measures which required syntax changes as the example below shows:

 

From

Measure 1 = CALCULATE(COUNTROWS())

 

To

Measure 1 = CALCULATE(COUNTROWS(Table1))

 

It appears the latest update of Power BI (app.powerbi.com) now requires the table name as a parameter of the COUNTROWS() function. 

 

 

 

 

 

View solution in original post


All Replies
Super User
Posts: 1,662
Registered: ‎12-15-2015

Re: Can't Display the Visual

@r_power12 Are you using import or DirectQuery to get data?
Frequent Visitor
Posts: 6
Registered: ‎02-24-2016

Re: Can't Display the Visual

ankitpatira I am using import data, sql queries pulling from an on-premise database.

 

The data loads and displays fine in Power BI Desktop, but the visuals present the error online in app.powerbi.com.

Frequent Visitor
Posts: 6
Registered: ‎02-24-2016

Re: Can't Display the Visual

After diving a bit deeper, I discovered the issue only affected some of my measures which required syntax changes as the example below shows:

 

From

Measure 1 = CALCULATE(COUNTROWS())

 

To

Measure 1 = CALCULATE(COUNTROWS(Table1))

 

It appears the latest update of Power BI (app.powerbi.com) now requires the table name as a parameter of the COUNTROWS() function. 

 

 

 

 

 

Frequent Visitor
Posts: 11
Registered: ‎10-18-2016

Re: Can't Display the Visual

 i am getting the same problem, whether i inport directly, from web , excel  or access . i am using free power bi desktop, the data gets loaded , but i cant get any visualisation

Highlighted
Regular Visitor
Posts: 44
Registered: ‎10-05-2016

Re: Can't Display the Visual

Same is hapening with me. I can see the data when go through edit query. But when load it and visualize it describes "Can not display the visual".

 

Recently i reinstall windows 7 and office 2010. Please help me in this scenario.

 

Regards,

 

Jamal Qamar

 

 

Frequent Visitor
Posts: 2
Registered: ‎11-10-2016

Re: Can't Display the Visual

Hello. I am having the same problem.... Even when I just create a small table with data inside PowerBI desktop, it doesnt display the visuals. What to do?...

New Member
Posts: 1
Registered: ‎11-17-2016

Re: Can't Display the Visual

power BI is not loading visuals , what to do 

Frequent Visitor
Posts: 5
Registered: ‎12-13-2016

Re: Can't Display the Visual

Hi, Please share if you found any solution.

Frequent Visitor
Posts: 5
Registered: ‎12-13-2016

Re: Can't Display the Visual

Hi, Please share if you found any solution. In my case if populate data even by "Enter Data" it says Can't display the visuals.

Thanks