Reply
Established Member
Posts: 137
Registered: ‎07-24-2015

Bug: table data not changed (filter from maximixed mode)

NV Frequent Visitor
Frequent Visitor
Posts: 11
Registered: ‎09-21-2015

Re: Bug: table data not changed (filter from maximixed mode)

This seems to be persistent with my experience as well. I've also expirienced similar issues with tables not responding correctly to any outside filters (slicers, vizualizations, page filters...). For example, you have to de-select a slicer filter and re-select it for the table to update.

 

When this is happening with regular filters, the issue is not in the fact that the calculations do not have time to run, because waiting wont help. Although, the reason might come from the fact that in these cases the data model has been quite complex and the calculations do not have time to instantly update. The table should however update as soon as the calculations are finished, which is not happening. Therefore I agree with this being a bug related to the table vizualization not updating to account for all active filters on the reporting page. Same applies for the matrix table vizualization. Other visualizations seem to respond as they should, which suggests that the data model complexity can't be the issue.

 

 

 

New Contributor
Posts: 544
Registered: ‎10-27-2015

Re: Bug: table data not changed (filter from maximixed mode)

I've seen similar issues around the matrix visual when auto-size columns was enabled or disabled (don't remember which was the bug state). This may be related in some way, as I imagine the two share some implementation details.

Established Member
Posts: 137
Registered: ‎07-24-2015

Re: Bug: table data not changed (filter from maximixed mode)

[ Edited ]

No @greggyb, this bug not similar "auto-size columns" bug.

 

You can reproduce this bug yourself using report from standard samples gallery in Power BI service - "Supplier Quality Analysis".

I'm recorded video bug report using this sample.

 

Highlighted
NV Frequent Visitor
Frequent Visitor
Posts: 11
Registered: ‎09-21-2015

Re: Bug: table data not changed (filter from maximixed mode)

Thanks, @greggyb! The auto-size (auto-size=TRUE) does not seem to fix the "filter from maximized mode"-bug, but suprisingly it did fix the problems I've had with regular slicers. I was able to fix a .pbix with this problem by enabling the auto-size option for the table. I'ts still a bug, but I rather have auto-size on, then un-responsive filters.

 

The topic of this post is however still unresolved.