cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Skemaz Member
Member

Browser Power BI Reports slow and some cards not loading - only on iPad

Hi

On my iPad Mini 2, in this report l see (a) very slow page load times, (b) if the page does load then some cards don't load at all, and (c) Browsers often crash.
I tested using Safari, FF and Chrome and they all give the same result.

I test on an iPad Mini 2 because many users still hang onto their older devices. However, users of the latest iPad Pro also report the same problem.
In Chrome I often see the "Aw, Snap! Something went wrong while displaying this web page".
In Safari I also often see "A problem occurred ..... so it was reloaded" then when it does load, some cards are missing or have "?" place-holders.

In FireFox after loading some of the visuals, I see a completely grey screen.

On any other device e.g. Android or Windows, the problem doesn't happen.

I noticed this post but it's dated and was never answered.

I'm sure I'm not the only person with iPad browser users, so maybe I'm doing something wrong.

Any assistance will be appreciated.

Thanks, Mark.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Skemaz Member
Member

Re: Browser Power BI Reports slow and some cards not loading - only on iPad

Hi

I have discovered the problem.

It is caused by the "Card with States" by OkViz. I will let them know about the problem.

If I change from "Card with States" to the standard "Card" control, the problem goes away.

Thanks for your time and interest.

Regards, Mark.

7 REPLIES 7
Community Support Team
Community Support Team

Re: Browser Power BI Reports slow and some cards not loading - only on iPad

Hi @Skemaz,

 

Please provide more detail contents about your issue, it will be help to clarify your scenario.

For instance: datasource type, issue visual type, connection mode, gateway type and setting, screenshots, other device(e.g. android) testing result...

 

In addition, if your issue related to web browsers compatibility, you can also submit a ticket for further support.

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



For learning resources/Release notes, please visit: | |
Skemaz Member
Member

Re: Browser Power BI Reports slow and some cards not loading - only on iPad

Hi Xiaoxin

Thanks for responding.

  1. Data Source Type: JSON files. Note even if I use a very small test data set with only a few hundred rows the problem still persists.
  2. Visual Types: As you can see if you click here to view my report, you'll notice that the reports are made up of Cards, and matrix matrix. Nothing fancy.
  3. Connection Mode: I import two sets of JSON files contained in two folders into my model. I have a single query for each folder that just loads the data. Subsequect queries transform the data. My code is all in M. No DAX code was required.
  4. Settings: The only settings that are "non-default" is that, in all but the final query containing the columns required by the report, "Enable Load" is turned off.
  5. Screen-shots: Rather than screen-shots, if you click here on whatever device you want to test on you'll see the results that I've described as well as the issue if you test using an iPad.
  6. Test results on different devices and browsers: This information is described in detail in my original post.

I appreciate your assistance. Thanks, Mark.

Community Support Team
Community Support Team

Re: Browser Power BI Reports slow and some cards not loading - only on iPad

Hi @Skemaz,

 

Which type of gateway you use, have you enabled the proxy? Where are your json data locate, local file or get data from web? Please tell me more about these.

BTW, does this issue appears on other reports which you view on mobile device?(not the same data source)

 

Regards,
Xiaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



For learning resources/Release notes, please visit: | |
Skemaz Member
Member

Re: Browser Power BI Reports slow and some cards not loading - only on iPad

Hi Xiaoxin

The JSON files are in a folder on my PC. I load the JSON files from that folder using a function that iterates through the file list in the folder and loads them all.

I then publish my dashboard to my Power BI professional account. There are no gateways involved.

I have created and tested other dashboards using the same method and this is the only report that creates the problem.

Please let me know if you need any additional information.

Thanks, Mark.

Skemaz Member
Member

Re: Browser Power BI Reports slow and some cards not loading - only on iPad

Hi Xiaoxin

I tried raising a support ticket but although I have a Pro account I get this message "Looks like you haven't subscribed to Power BI Pro".

I suspect that the issue may be that I received the 365 days free evaluation that MS offered a few months ago to those people already active in the service - not sure - just guessing?

Anyway, this is an example of a report I made that uses Excel workbooks as an imported data source. I then publish the report to my tennant using my Pro accont.

Click here to view the report.

The above report runs well on my iPad.

I'm beginning to suspect that 6 of the card controls are causing the problem. I tested this by removing them from:

This test report - click here to view it.

You'll notice that it is missing the 6 card controls in the top-right shown in the version below. I notice that the above loads Ok on my iPad.

However, the version that *does* have the cards (see below), fails to load the cards, craches the browser etc (see my earlier posts for details). This only happens on myiPad (using any browser).

This is the report that still has the card controls and causes the issues - click here to view it.

Your assistance is greatly appreciated.

Thanks, Mark.

Skemaz Member
Member

Re: Browser Power BI Reports slow and some cards not loading - only on iPad

Hi

There seems to be an issue with the URL that I supplied for the 2nd last link above.

Here it is again:

Click here.

Thanks, Mark.

Highlighted
Skemaz Member
Member

Re: Browser Power BI Reports slow and some cards not loading - only on iPad

Hi

I have discovered the problem.

It is caused by the "Card with States" by OkViz. I will let them know about the problem.

If I change from "Card with States" to the standard "Card" control, the problem goes away.

Thanks for your time and interest.

Regards, Mark.