cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
michaelhowarth Frequent Visitor
Frequent Visitor

Blank Matrices

We've noticed that, since Saturday 18/Nov/17, an issue has arisen with our Matrix visual on Service - the table appears to contain no data when viewed in Service. All columns and headers appear, but the actual grid appears to be blank.

 

When the data is Exported into Excel, it's all there; also, the visual looks fine and shows expected data in Desktop. It's only in Service that the issue occurs.

 

This issue appears to have started just after the North Europe downtime on Friday 17/Nov - possibly related?


Are any other users experiencing this issue over the last few days, and if so, can you recommend a workaround?

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-jiascu-msft Super Contributor
Super Contributor

Re: Blank Matrices

Hi All,

 

This issue has been fixed.

 

Best Regards,

Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
15 REPLIES 15
Robot Frequent Visitor
Frequent Visitor

Re: Blank Matrices

We're having the same problem: in the pbix file, the matrix visual looks as it should, but when viewed online in the Power BI Service, the data in all columns (defined as 'values' in the visualisations bar) are blank, and all column headers are repeated, i.e. previously, the column headers were A, B, C, D and E, but now, they are A, B, C, D, E, A, B, C, D, E.

rvgfox Frequent Visitor
Frequent Visitor

Re: Blank Matrices

Same problem for us

v-jiascu-msft Super Contributor
Super Contributor

Re: Blank Matrices

Hi All,

 

Since many users encountered this issue. Please check the list below, Then create a support ticket if needed: https://powerbi.microsoft.com/en-us/support/.

1. Please upgrade the PBI Desktop to the latest version. PBI Service and Desktop always are upgraded for the new feature all the time.

2. If you use a Matrix visual in you own workspace, which means the visual isn't a shared content. 

3. If RLS is applied in the dataset.

4. If you still can create a Matrix visual in the Service. 

 

It works fine in my side.

 

Best Regards!

Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
rvgfox Frequent Visitor
Frequent Visitor

Re: Blank Matrices

Hi Dale,

 

The problem, I'm sure it's in the service.

 

I've several reports with matrix an another visuals working months ago, and some time (on Monday 20/11) that reports it doesn't work.

 

If I design a new report (with the last version of PBI Desktop), it works in the desktop but not in the service.

 

Regards.

 

Ramon

KiwiAbroad Frequent Visitor
Frequent Visitor

Re: Blank Matrices

Same issue for me. Looks fine and as intended in Desktop, just get the frame when uploaded to the Service.
KiwiAbroad Frequent Visitor
Frequent Visitor

Re: Blank Matrices

Hi Dale, I have the same issue as Ramon. Checked off your list... these are not the issue.
v-jiascu-msft Super Contributor
Super Contributor

Re: Blank Matrices

Hi, 

 

Is this issue the same with this one: https://community.powerbi.com/t5/Issues/Matrix-visual-doesn-t-show-data-ANYMORE-if-there-is-not-fiel...?

 

How can I reproduce this issue?

 

Best Regards!

Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
KiwiAbroad Frequent Visitor
Frequent Visitor

Re: Blank Matrices

Yep.  That's extractly the issue.  Dragged a field into "columns" and everything is well with the world again.  THANKS!

 

Would be great if the Matrix viz worked as before.  I now have the issue of the columns auto-sizing rather than wrapping.  Is there a solve for this!!!

Robot Frequent Visitor
Frequent Visitor

Re: Blank Matrices

Hi Dale,

 

Yes the issue is the same issue as https://community.powerbi.com/t5/Issues/Matrix-visual-doesn-t-show-data-ANYMORE-if-there-is-not-fiel...   and   https://community.powerbi.com/t5/Service/matrix/m-p/307400#M35599, except that
*** I am not able to drag a value into the 'Columns' area. If I try, the field does not appear in the 'Columns' area. This function does not work.***

 

I  have tried downloading the most recent version of Power BI Desktop, saving the pbix file in that version, and publishing that to the Service, it doesn't fix the problem.

 

To answer your questions :

- The report and visual are not in my workspace, they are in a workspace that has many members (colleagues at our company).

- RLS is indeed applied in the dataset.

- Yes we can still create a Matrix visual in the Service. However, it has the same problem - no data appearing on screen in the on-screen columns of the matrix visual.

 

Has a change recently been made to the matrix visual?

Helpful resources

Announcements
Community Kudopalooza

Win Power BI Swag with Community Kudopalooza!

Each week, complete activities and be qualified in the drawing for cool Power BI Swag.

Summit North America

Power Platform Summit North America

Register by September 5 to save $200

Virtual Launch Event

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

MBAS Gallery

Watch Sessions On Demand!

Continue your learning in our online communities.

Top Kudoed Authors
Users Online
Currently online: 172 members 1,785 guests
Please welcome our newest community members: