cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DataUpperCut
Helper I
Helper I

Azure Synapse Analytics (SQL DW) not available in Manage Gateway

I am trying to configure Azure Synapse Analytics (SQL DW) on Data Gateway however the option to choose connector for 
"Azure Synapse Analytics (SQL DW)" is not available in the drop down. On Power BI Desktop its available.

 

Is it bug?

1 ACCEPTED SOLUTION
DataUpperCut
Helper I
Helper I

@GilbertQ  in our enviornment it is allowed to enable this setting by the security and infrastucture team, so i give it a shot and chose SQL Server as a conector to configure data source on the data gateway and it worked.

However i must say it weird that it has worked when the connector on the PBI desktop is different and on gateway is different.

View solution in original post

5 REPLIES 5
GilbertQ
Super User
Super User

Hi @DataUpperCut 

 

Yeah understood it should then be working. You might need to chat to the security and infrastucture team to get it working!





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

DataUpperCut
Helper I
Helper I

@GilbertQ  in our enviornment it is allowed to enable this setting by the security and infrastucture team, so i give it a shot and chose SQL Server as a conector to configure data source on the data gateway and it worked.

However i must say it weird that it has worked when the connector on the PBI desktop is different and on gateway is different.

GilbertQ
Super User
Super User

Hi @DataUpperCut 

 

You should be able to just upload this to the Power BI Service and when you go into the data source connections in the dataset settings there will be an option to edit the credentials for the data source.


What this means is you should not need the gateway to connect to Azure Synapse Analytics because it is a Microsoft Azure Service.





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

@GilbertQ you are right, and as per the documentation as well Azure Synapse Anlaytics does not require gateway, however for that to work the setting below should be enabled, which in our enviornment its not and that why i am looking for the alternate.

  1. Sign in to the Azure portal.
  2. Go to the Azure SQL database for which you're configuring refresh.
  3. At the top of the Overview blade, select Set server firewall.
  4. On the Firewall settings blade, make sure that Allow Azure services and resources to access this server is set to Yes.

Yeah thanks for that I would expect it to then be working.

 

Maybe it takes a bit of time before the changes take place?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors