cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
ShWoloshin Frequent Visitor
Frequent Visitor

Authentication problems-working in Power BI Desktop and not Power BI Service.

I have created a dataset that utilizes both NAV web services (connected using Windows Credentials in the desktop) and D365 CRM (connected using O'Data in the desktop). Neither source is on prem and both connect and update perfectly well in Power BI Desktop. When prompted for credentials in Power BI Service, I cannot get either data source to connect.
For the NAV Web Services source, using Windows credentials in the desktop, I use the"use other credentials" option to identify the client's credentials. This option is not available in the service. I have also tried Basic authentication and it fails as well.
For the D365 CRM source, using the O'data credentials in the desktop, I am redirected to an on premise ADFS server, utilized by my client. In the service, this redirection does not happen. Copies of error messages are below:

Basic Authentication to NAV Web Services:
Failed to update data soruce credentials: The credentials provded for the OData source are invalid (Source at http:-----------/Dev/odata/company('-----')

2 REPLIES 2
Community Support Team
Community Support Team

Re: Authentication problems-working in Power BI Desktop and not Power BI Service.

@ShWoloshin ,

 

The credentials should be windows credentails which is same with that in desktop when connect to NAV and also check if Odata feed URL is valid.  However, I would suggest you to use content pack or app instead in power bi service: 

 

https://docs.microsoft.com/en-us/dynamics-nav-app/across-powerbi

https://docs.microsoft.com/en-us/dynamics365/customer-engagement/admin/use-power-bi

 

Community Support Team _ Jimmy Tao

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

ShWoloshin Frequent Visitor
Frequent Visitor

Re: Authentication problems-working in Power BI Desktop and not Power BI Service.

This is custom reporting that uses merged data from D365 and NAV.  I am not seeing how the content pack helps us.  I have both data sources working and refreshing in Power BI Desktop (using the methods described in the articles you cite.  Why aren't the same credentials working in the service?