cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Apply filter to Power BI Tile in Power Apps

I have a PowerApp with a PowerBI report displayed according to this link: Integrating Power BI Reports on Power Apps Screen - Power of Power Platform. I have also tried embedding a single chart at a time. 

 

I then followed this link to apply filters in URL as follows: Power BI tile control in Power Apps - Power Apps | Microsoft Docs with this syntax structure: 

&$filter=<TableName>/<ColumnName> eq '<Value>'

Omitting the <> of course.

 

However my charts/reports do not change at all. I've tried filtering on other fields/tables to make sure it isn't restricted to the field. Also ensured the field is a string type. 

 

Any ideas how I can achieve this? Thank you 

 

3 REPLIES 3
nickyvv
Community Champion
Community Champion

Hi @Anonymous,

 

And which technique did you use?

  • Embed a Power BI tile via the Chart menu and then configure the workspace/dashboard/tile
  • Or embed a Power BI report via the embed code, as mentioned further along the report

Can you share the exact URL you are using, starting from the &$filter part?



Did I answer your question? Mark my post as a solution!

Proud to be a Super User!


Blog: nickyvv.com | @NickyvV


Anonymous
Not applicable

Hi @nickyvv , thank you so much for responding!

 

So I have tried both but right now I am using the embed Power BI Tile and manually setting the TileUrl to the Report's embed in Webpage/Portal url, as per the first link in my post.

 

My TileUrl now reads as follows: "https://app.powerbi.com/reportEmbed?reportId=someguid&autoAuth=true&ctid=....&config=...&filterPaneE... eq 'Cash'" 

 

So: &$filter=PricingModelTbl/PricingModelName eq 'Cash'" 

Hi @Anonymous, 

 

thanks for waiting for the response. In case you haven't solved it:

I'm struggling to find if you took the right approach to the URL filtering.

On this page you mentioned, there are 2 ways of filtering, using the new or the old API.

According to your TileUrl, I think you are using the new one (because you use reportEmbed?...), but your filter part uses the old syntax. When using the old API, the URL should look something like this:

nickyvv_0-1629878440252.png

 

Can you confirm that AllowNewAPI is set to false? Or did you not set that at all?

 



Did I answer your question? Mark my post as a solution!

Proud to be a Super User!


Blog: nickyvv.com | @NickyvV


Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.

Top Solution Authors
Top Kudoed Authors