cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ksr
Frequent Visitor

App not applying filters which are used in the underlying Report in the Workspace

I have uploaded a report in the Workspace and updated the app.

 

But the filters and critierias applied on visuals in the report are not displayed in app(even after updating the app).

 

The report is displaying the desired filters.

 

Any ideas/solution for this?

 

1 ACCEPTED SOLUTION

Hi @v-easonf-msft ,

 

The issue was resolved by a reseting all filters using the button in the top right section of the app. 

ksr_0-1641201039022.png

However, I had raised a ticket with Microsoft Support Team as well. Their suggestions were as follows:

 

Option 1: Unpublish the exisitng app. Create another app of the same report and publish.

Option 2: Replace the existing report by reuploading the pbix. Update the app.

  

Thanks for your prompt replies and ideas @HashamNiaz & @v-easonf-msft

 

Best regard,

ksr 

View solution in original post

4 REPLIES 4
v-easonf-msft
Community Support
Community Support

Hi, @ksr 

Could you please tell me whether your problem has been solved?

If yes, you can accept the helpful answer as solution to close this thread.

You could also share your own solution here. It will help other community members easily find the solution when they get the similar issue.

 

Best Regards,
Community Support Team _ Eason

Hi @v-easonf-msft ,

 

The issue was resolved by a reseting all filters using the button in the top right section of the app. 

ksr_0-1641201039022.png

However, I had raised a ticket with Microsoft Support Team as well. Their suggestions were as follows:

 

Option 1: Unpublish the exisitng app. Create another app of the same report and publish.

Option 2: Replace the existing report by reuploading the pbix. Update the app.

  

Thanks for your prompt replies and ideas @HashamNiaz & @v-easonf-msft

 

Best regard,

ksr 

v-easonf-msft
Community Support
Community Support

Hi, @ksr 

Is there a similar situation when uploading new reports on other  workspace and publishing a new app?

If you still have no idea about your problem, you can also open a support ticket with MSFT to seek technical support , usually they will have better suggestions.

 

Best Regards,
Community Support Team _ Eason

HashamNiaz
Super User
Super User

Hi @ksr !

If possible, please try to create a new app from the workspace. Sometimes Power BI Apps didn't sync slicers when you update the base report.

 

Regards,

Hasham

Helpful resources

Announcements
Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

charticulator_carousel_with_text (1).png

Charticulator Design Challenge

Put your data visualization and design skills to the test! This exciting challenge is happening now through May 31st!

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Power BI Release May 2022 768x460.png

Check it out!

Click here to read more about the May 2022 updates!

Top Solution Authors
Top Kudoed Authors