cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
russb Frequent Visitor
Frequent Visitor

App issues in Service. Reports not visible in App and Dataset is visible. Permissions emails missing

Over the past few days we are seeing behavior in a published Power BI App that appears to be a service issue. When we remove and then add a report back to an App and update the app we can see the Dataset but not the Report. Also the previous URL that navigated to the Report in the App is not functioning and shows an error message that says "Sorry, we couldn't find that report. It may have been deleted or you may not have access to view it."

 

Also we noticed when updating an app that the emails we previously had in the "Permisson" page are now missing. Meaning it seems to not store who has been granted access to the App in the service when we are in the "Update App" flow.

 

Help! Our users of the App rely on the URL to navigate to the published reports within the App.

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: App issues in Service. Reports not visible in App and Dataset is visible. Permissions emails mis

Hi @russb,

 

By my tests again, I still cannot reproduce your issue. I have tests with IE and Google chrome.

 

I have tests with removing one of the report in that published app or adding an new report to that app, everything works as expected.

 

Please try the solutions below.

 

 1. Clear your browser's cache and cookies and try again. 

 

 2. You also could try with InPrivate Window.

 

 3. Please Unpublish your app and Publish it again, then try again.

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
6 REPLIES 6
Community Support Team
Community Support Team

Re: App issues in Service. Reports not visible in App and Dataset is visible. Permissions emails mis

Hi @russb,



 

By my tests based on your description, everything works as expected.

 

Here is my steps. In addition, do you assign your app in premium capacity?

 

1. Publish an app in cherry03 workspace.

2. Remove one of the reports and then update the app, copy the app url and open it, I cannot see that report.

3. Add the report which I removed in step 2 in the app and update the app, copy the url and open it, I could see that report and the dataset.

4. If I unpublish the app and open the previous url in the step 3, it will show the error message "Sorry, we couldn't find that report. It may have been deleted or you may not have access to view it".

 

Please check if my steps are similar to your scenario.

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
russb Frequent Visitor
Frequent Visitor

Re: App issues in Service. Reports not visible in App and Dataset is visible. Permissions emails mis

Thank you Cherry for your testing. What was not working is a modification of your step 3. If we add a new report to an existing App that rpeort is not showing up even after we hit the "Update App" button and go through that workflow.

 

Also, removing a Report from an App and then adding it back to the App results in the Report not being visible in the App anymore.

 

The final issue we are seeing is when we go through the Update App process we have specific Security Groups that that App is shared with. Those Security Groups are missing and we have to enter them again every time we update the App.

 

We do not have Permium capacity at our location. Thanks!

Community Support Team
Community Support Team

Re: App issues in Service. Reports not visible in App and Dataset is visible. Permissions emails mis

Hi @russb,

 

By my tests again, I still cannot reproduce your issue. I have tests with IE and Google chrome.

 

I have tests with removing one of the report in that published app or adding an new report to that app, everything works as expected.

 

Please try the solutions below.

 

 1. Clear your browser's cache and cookies and try again. 

 

 2. You also could try with InPrivate Window.

 

 3. Please Unpublish your app and Publish it again, then try again.

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Community Support Team
Community Support Team

Re: App issues in Service. Reports not visible in App and Dataset is visible. Permissions emails mis

Hi @russb,

 

Have you solved your problem?

 

If you have solved your problem, please always accept the replies making sense as solution to your question so that people who may have the same question can get the solution directly.

 

If you still need help, please feel free to ask.

 

Best  Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
russb Frequent Visitor
Frequent Visitor

Re: App issues in Service. Reports not visible in App and Dataset is visible. Permissions emails mis

We've found unpublishing and republishing the App is the only way to get new Reports or removed Reports to properly reflect in the App. We've tried private browser windows and Chrome, IE, and Edge. We have a ticket opened with MIcrosoft to resolve.

Thanks.

russb Frequent Visitor
Frequent Visitor

Re: App issues in Service. Reports not visible in App and Dataset is visible. Permissions emails mis

I will accept your reply as a solution for most issues. In our particular case that did not solve the problem and Microsoft is looking into the issue. We have opened a ticket and they are investigating the App behavior of our Tenant. It is not acting as expected.