cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Satch
Helper III
Helper III

Apostrophe keeps giving '

Hi

 

Have a column with an apostrophe in the name, like 90's

In Desktop version it shows OK, but on Service it shows 90's

 

So I replaced in query editor the ' to ""

So in desktop there's now 90s

 

But strangeeee. In Service there's still 90's

 

I cannot see why, since i changed it. It shouldn't know of any '

 

Any help appreciated

1 ACCEPTED SOLUTION

Thanks Eyelyn for your reply,,

 

because of your post it did me try out to make a testset and upload it to service.

Then all was good.

 

So knowing that it can be good in my setup I tried delete the original set in the Service and replaced it.

Then all was good there also.

 

So it's a caching thing it looks like.

Overwrite existing report/dataset doesn't work.

Delete and upload again did the trick.

 

Thanks

View solution in original post

4 REPLIES 4
Eyelyn9
Community Support
Community Support

Hi @Satch ,

 

Everything seems fine on my side.

1.21.2.1.PNG

 

Please upgrade the Desktop to the latest version and have a try again.

 

 

If it does not make sense, please provide me with more details about your table and your problem or share me with your pbix file from your Onedrive for Business after removing sensitive data.

 

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks Eyelyn for your reply,,

 

because of your post it did me try out to make a testset and upload it to service.

Then all was good.

 

So knowing that it can be good in my setup I tried delete the original set in the Service and replaced it.

Then all was good there also.

 

So it's a caching thing it looks like.

Overwrite existing report/dataset doesn't work.

Delete and upload again did the trick.

 

Thanks

lbendlin
Super User
Super User

Every time you make structural changes ( and modifying the query is such a change) you need to republish the app to allow that structural change to flow through (together with the data refresh)

I did publish the set again to the service.

And then it's still there

Helpful resources

Announcements
Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

charticulator_carousel_with_text (1).png

Charticulator Design Challenge

Put your data visualization and design skills to the test! This exciting challenge is happening now through May 31st!

Power BI Dev Camp Session 22 768x460.jpg

Check it out!

Mark your calendars and join us on Thursday, May 26 at 11a PDT for a great session with Ted Pattison!

Top Solution Authors
Top Kudoed Authors