cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TTAZNG__
Frequent Visitor

Analysis Services Partition manual Refresh fails - "Paramter Name already Exists"

We have large datasets utilizing incremental update.  Refreshing takes too long and times out.   To update we use SSMS and manually reload partitions 1 at a time.  When I use the GUI to attempt this I get an error:  "Paramter Name Already Exists.   Parameter name:  name (Microsoft.AnalysisServices.backend)."    This is verbatim - spelling error included.   My workaround is to generate the script and execute it in an SSMS Query window. 

 

 

12 REPLIES 12
Aburar_123
Super User
Super User

Hi @TTAZNG__ , Please restart your PC and check again.

LalitHCL
Advocate I
Advocate I

Its a known issue from so long. Luckily i cracked this issue. 

Two things to do to resolve this issue.

1. While connecting using analysis service is SSMS, do not provide any value in connect to database option. Rather leave it to default 

2. In the server name do not provide initial catalog. Instead remove that string part.

 

It will work once both above options are done.

 

Please mark it as answer if that works for you 🙂

Give that man an award !!!!! 
Thanks !!!!! 

Thank you so much. Your solution solved it! 😁

Removing the initial catalog solved this.

Thank you very much!!!

GilbertQ
Super User
Super User

It appears to be an error with the paramter name? If you could confirm there is a single RangeStart and RangeEnd parameter that is configured as DateTime?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

TTAZNG__
Frequent Visitor

Additional Info:  Incremental column is defined as a Date (Oracle) which is formatted as (2012-09-30 00:00:00).  

v-stephen-msft
Community Support
Community Support

Hi @TTAZNG__ ,

 

It may be because the parameter configuration is incorrect.

Please review step-by-step information in Configure incremental refresh.

 

Reference: Troubleshoot incremental refresh

 

 

Best Regards,

Stephen Tao

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thank you for your response.   Parameters are set up correctly.  This error only occurs for my PC.  Other team members do not have this issue. 

GilbertQ
Super User
Super User

Hi @TTAZNG__ 

 

Could you please make sure you have got the lastest version of SSMS installed, it currently is 18.9.1

 

If you get an error when processing the partition just ignore it and wait for it to complete.

 

You can download the latest version of SSMS here: https://aka.ms/ssmsfullsetup





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Thanks for taking time to reply.  I have completely uninstalled, rebooted and reinstalled SSMS version 18.9.1.  It must be something on my pc as others on my team do not experience this error on their PCs.   I had a team member use my pc with his credentials and error still occurred.

Helpful resources

Announcements
November 2022 Update

Check it Out!

Click here to read more about the November 2022 updates!

Microsoft 365 Conference â__ December 6-8, 2022

Microsoft 365 Conference - 06-08 December

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power BI Dev Camp Session 27

Ted's Dev Camp

This session walks through creating a new Azure AD B2C tenant and configuring it with user flows and custom policies.

Top Kudoed Authors