Showing results for 
Search instead for 
Did you mean: 
k3rz0rg Member

Adding the file path to the gateway cluster!

Hi all,


I created a report with an excel file as source and published that on my workspace.

Now I wanted to add that file source to my gateway cluster but when I provide the full path, it gives me following error →

gateway file source error.JPG



I have other gateways under the same cluster where the source type is Folder and they are working fine, refreshes with the files inside the folders but in this case, I am unable to add the gateway.

Any ideas what I am doing wrong here?




Ross73312 Super Contributor
Super Contributor

Re: Adding the file path to the gateway cluster!

Your filepath is the problem.  Whenever you connect to your files you should use the format "\\Server\Folder\File.ext".  The path in your screenshot is "Drive:\Folder\File.ext"


You will likely need to update your PBIX file and the gateway to make use of a network folder that is accessable by both your Gateway and your Power BI Desktop.


              Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!


k3rz0rg Member

Re: Adding the file path to the gateway cluster!

Hi @Ross73312,


yes you were right and I fixed that thing, yet no luck. I changed the source (even though I was on the local machine) to the detailed path and it worked inside the PBID and then published. The connection is fine through the personal gateway, however if I wanted to add the path to the enterprise gateway, there the problem arises.


As you can see below the connection is going good with the personal one.




Gateway details 1.JPG


Then I tried to add that path to enterprise.


Gateway details 2.JPG

File path is correct this time. 

Gateway details 3.JPGI tested that path by browsing from the server and it asked for my local credential and then the file got opened.
I can't figure out why this is popping up no matter what method I use.



Unable to connect: We encountered an error while trying to connect to . Details: "We could not register this data source for any gateway instances within this cluster. Please find more details below about specific errors for each gateway instance."Hide details

Activity ID:e8c466f8-becf-47e3-bd32-7ec0191515b1
Request ID:518ba00b-914b-6ae0-f1b7-2b42afd5bdbb
Cluster URI:
Status code:400
Error Code:DMTS_PublishDatasourceToClusterErrorCode
Time:Fri Aug 03 2018 10:50:57 GMT-0400 (Eastern Daylight Time)
SAE-PBDevelopment:Invalid connection credentials.
Underlying error code:-2147467259
Underlying error message:The credentials provided for the File source are invalid. (Source at \\\home$\user\workhours.xlsx.)
Ross73312 Super Contributor
Super Contributor

Re: Adding the file path to the gateway cluster!

Is the path you placed into your Enterprise Gateway settings now exactly the same as what is displayed in your Power BI Project file?  You should be able to see this if you click on the drop arrow below "Edit Queries" and select "Data Source Settings".   What is in there must match 100% of what you will enter into the gateway settings.


              Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!


Microsoft v-yulgu-msft

Re: Adding the file path to the gateway cluster!

Hi @k3rz0rg,




As error prompted, please verify that you have the correct username and password. Also verify that those credentials can successfully connect to the data source. Make sure the account being used matches the Authentication Method.



Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Ria_ Frequent Visitor
Frequent Visitor

Re: Adding the file path to the gateway cluster!



I Just got success after getting the same error and hope this helps. Please note I use a mapped drive to access my data so it may be slighllty different but worth a shot. There were two problems:


1. The username and password I was usuing. For me, I needed to use the credentials used to get on to the server I was using as those are the windows credentials that server uses. Originally I was trying to use my actual windows log in and getting frustrated. 


2. You have to use your UNC (universal naming convention) as your file path, not the drive name AND it has to be the same on your actual power BI desktop file before you can connect it via the online power BI service. 


Here is how you get your UTC :

Go to search in bottom left of desktop, type "run" and hit enter 

type "cmd" hit enter

type "net use" hit enter

you will get \\and anything after those charaters is you UTC


Once you have your UTC: 

Open your actual power Bi desktop file - go to file, options and settings, data source settings. 

Click on each local file and replace the drive portion of your file path with your UTC.

Make sure to refresh and then save and publish your power bi file.


After it publishes you can log back on to the power BI service and go to your scheduled refesh. Under the gatway you will see the connections included in the data set. Now you can add each one to the gatway cluster just make sure you use the corrected username and password.


Helpful resources

Exclusive LIVE Community Event #3 – Ask Arun Anything

Exclusive LIVE Community Event #3 – Ask Arun Anything

Join us in the third Triple A event!

Meet the 2020 Season 1 Power BI Super Users!

Meet the 2020 Season 1 Power BI Super Users!

It’s the start of a new Super User season! Learn all about the new Super Users and brand-new tiered recognition system.

Super User Challenge: Can You Solve These?

Super User Challenge: Can You Solve These?

We're celebrating the start of the New Super User season with our first ever Super User 'Can You Solve These?' challenge.

Power BI Desktop Update - February 2020

Power BI Desktop Update - February 2020

We are super excited for our update this month, as we are releasing two of our top community requests!

Power Platform Online Conference

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

Top Solution Authors