Reply
Regular Visitor
Posts: 41
Registered: ‎09-21-2017

Adding the file path to the gateway cluster!

Hi all,

 

I created a report with an excel file as source and published that on my workspace.

Now I wanted to add that file source to my gateway cluster but when I provide the full path, it gives me following error →

gateway file source error.JPG

 

 

I have other gateways under the same cluster where the source type is Folder and they are working fine, refreshes with the files inside the folders but in this case, I am unable to add the gateway.

Any ideas what I am doing wrong here?

 

Thanks,

K3

Super User
Posts: 1,830
Registered: ‎02-28-2017

Re: Adding the file path to the gateway cluster!

Your filepath is the problem.  Whenever you connect to your files you should use the format "\\Server\Folder\File.ext".  The path in your screenshot is "Drive:\Folder\File.ext"

 

You will likely need to update your PBIX file and the gateway to make use of a network folder that is accessable by both your Gateway and your Power BI Desktop.


   

              Did I answer your question? Mark my post as a solution!
       

Proud to be a Datanaut!


   


Regular Visitor
Posts: 41
Registered: ‎09-21-2017

Re: Adding the file path to the gateway cluster!

[ Edited ]

Hi @Ross73312,

 

yes you were right and I fixed that thing, yet no luck. I changed the source (even though I was on the local machine) to the detailed path and it worked inside the PBID and then published. The connection is fine through the personal gateway, however if I wanted to add the path to the enterprise gateway, there the problem arises.

 

As you can see below the connection is going good with the personal one.

 

 

 

Gateway details 1.JPG

 

Then I tried to add that path to enterprise.

 

Gateway details 2.JPG

File path is correct this time. 

Gateway details 3.JPGI tested that path by browsing from the server and it asked for my local credential and then the file got opened.
I can't figure out why this is popping up no matter what method I use.

 

Error:

Unable to connect: We encountered an error while trying to connect to . Details: "We could not register this data source for any gateway instances within this cluster. Please find more details below about specific errors for each gateway instance."Hide details

Activity ID:e8c466f8-becf-47e3-bd32-7ec0191515b1
Request ID:518ba00b-914b-6ae0-f1b7-2b42afd5bdbb
Cluster URI:https://wabi-us-east2-redirect.analysis.windows.net
Status code:400
Error Code:DMTS_PublishDatasourceToClusterErrorCode
Time:Fri Aug 03 2018 10:50:57 GMT-0400 (Eastern Daylight Time)
Version:13.0.6109.175
SAE-PBDevelopment:Invalid connection credentials.
Underlying error code:-2147467259
Underlying error message:The credentials provided for the File source are invalid. (Source at \\netapp2.company.local\home$\user\workhours.xlsx.)
DM_ErrorDetailNameCode_UnderlyingHResult:-2147467259
Microsoft.Data.Mashup.CredentialError.DataSourceKind:File
Microsoft.Data.Mashup.CredentialError.DataSourcePath:\\netapp2.company.local\home$\user\workhours.xlsx
Microsoft.Data.Mashup.CredentialError.Reason:AccessUnauthorized
Microsoft.Data.Mashup.MashupSecurityException.DataSources:[{"kind":"File","path":"\\\\netapp2.company.local\\home$\\user\\workhours.xlsx"}]
Microsoft.Data.Mashup.MashupSecurityException.Reason:AccessUnauthorized
Super User
Posts: 1,830
Registered: ‎02-28-2017

Re: Adding the file path to the gateway cluster!

Is the path you placed into your Enterprise Gateway settings now exactly the same as what is displayed in your Power BI Project file?  You should be able to see this if you click on the drop arrow below "Edit Queries" and select "Data Source Settings".   What is in there must match 100% of what you will enter into the gateway settings.


   

              Did I answer your question? Mark my post as a solution!
       

Proud to be a Datanaut!


   


Highlighted
Community Support Team
Posts: 5,652
Registered: ‎09-21-2016

Re: Adding the file path to the gateway cluster!

Hi @k3rz0rg,

 

1.PNG

 

As error prompted, please verify that you have the correct username and password. Also verify that those credentials can successfully connect to the data source. Make sure the account being used matches the Authentication Method.

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.