cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Access Shared Power BI report (External user) - Hanging

For the last six months I have been developing Power BI reports that I have shared with users that our outside my domain.  My users have now come back to me indicating that they can no longer access these reports.

 

Note I've tested this experience myself by using a user account that I have that is external to the reporting domain.  I am able to add users via the Share Report experience.  I received the email granting me access, clicked on the link; however, the session just hangs with a "loading" message that does not disappear.  There is no message that comes back from the service with a "denied" access message....the reports just sits there saying "loading".   This only happens to users who are outside my domain.  All internal users are able to acces reports with no issues.

 

Please help.

1 ACCEPTED SOLUTION

Accepted Solutions

Final Update

After numerous escalations, my issue was finally raised to Microsoft technical support and resolved.

Here is the summary of the closure of this ticket. Note the support engineer was from China so the English translation of the trouble ticket may be confusing to some.

 

Basically the B2B tunnel for my report for external users was not working. The workaround was to create a new B2B tunnel to our Tenant. Once a user used this new B2B tunnel, the original B2B tunnel became functional again. The Microsoft support engineer could not comment on why this fixed the issue.....only that it does fix the issue.

Ticket Number: 120073026000052 (This is the trouble ticket that was raised by Microsoft to manage my issue)

 

Problem Description: Some user found themselves forever looping into loading page after open Power BI B2B invite Link. ========================================

Resolution: Access to B2B Share Link home page could mitigated issue:  This action only need to be done once for each influenced user. We recommended to add this workaround to option message in sharing window for your convenience. Note(Aug-13): It is confirmed that there are three influenced user’s issue is mitigated via above method. ========================================

 

View solution in original post

13 REPLIES 13
Resident Rockstar
Resident Rockstar

Hi @kdelosh ,

 

Could this be the issue:

Power BI rolled out enforcement of TLS 1.2 protocol for all encrypted connections in all regions. All modern web browsers (Edge, Firefox, Chrome, Safari and Internet Explorer 11) support TLS 1.2. Any customers having connection issues should ensure they are using the latest web browser of their choosing. Any client/server connections (such as API/Embedded calls, Mobile apps etc) also must support TLS 1.2 in order to maintain connection to Power BI service. Customers using Embedded applications/API's and seeing exceptions related to failed SSL connection and/or handshake failures should refer to instructions and For more information, please refer here (https://powerbi.microsoft.com/en-us/blog/deprecating-tls-1-0-and-1-1-support-in-power-bi/)

 

Or, is it possible that security settings/firewall settings have changed in your environment?

 

I would appreciate Kudos if my response was helpful. I would also appreciate it if you would Mark this As a Solution if it solved the problem. Thanks!

@collinq 

 

I have an external account that I used to test access to my reports.  I can confirm that I too suffer from the same issue and I've tested my browser to see if it supports TLS 1.2.  It does.

 

Here is the link that I used to test my browser:  https://clienttest.ssllabs.com:8443/ssltest/viewMyClient.htm...

 

I've raised a trouble ticket internally to check for any security/firewall changes....no word back yet.

 

Regards,

 

Kerry

Note.  I believe Microsft hosts the reports on their servers correct?  When I check About Power BI I see that my data is stored in Australia Southeast (Victoria).

 

So the issues is either someone on my side has changed the Power BI Export and sharing settings (via Admin Portal) or the issue resides on Microsoft side?

 

I am chasing internally to find out who has Power BI admin rights to check the tenant settings.

 

Regards,

 

Kerry

 

 

Community Support
Community Support

hi  @kdelosh 

A similar issue had been submitted to power bi product team and they are doing test on it, ICM:195050809

I will update here once I get any information.

 

Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 @v-lili6-msft 

 

Hi Lin,

 

can you please detail issue being worked on under ticket number ICM:195050809?  I would like to understand why you believe they are related.  I need to feed back to my management team that this fix has the potential to fix my issue as well.

 

Regards,

Kerry

hi  @kdelosh 

ICM:195050809

CSS - Report shared by external user keeps loading

Problem:

  1. Problem description (Simple version of the problem as perceived by the Customer): Cx is trying to open a report shared by an external user. When the link opens in the browser, it keeps loading forever. Customer is using latest Google chrome browser. The cx has pro license and been added as Guest user with "Admin" role.

 

Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-lili6-msft   Lin,

 

any updates on progress with this issue?  What is the current estimate for correction of this issue?

 

Regards,

 

Kerry

 

hi  @kdelosh 

 

'content edited by Admin'

 

I have tested it just now, it works well on my side, I use @xxxxUS.onmicrsofrt.com account to share a report with  @microsoft.com, this works well on @microsoft.com account.

 

Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-lili6-msft ,

 

I can tell you this issue is still a problem on my tenant.

 

I am hosted on Australia Southeast (Victoria).

 

How do you ensure that what ever fix corrected the  original problem gets pushed out to my host?  Ie what is the rollout timeframe to get this fix rolled out across the world?

 

Regards,

 

Kerry

Helpful resources

Announcements
November Update

Check it Out!

Click here to read more about the November 2020 Updates!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

secondImage

Power Platform October Community Highlights

Check out the top community contributors across all of the communities

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors