cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DSimma Regular Visitor
Regular Visitor

A group Measures stop calculating after a refresh

Has anyone seen an issue where a group of measures works fine in the Desktop app, but when you refresh that report through the service, the measures stop calculating? 

 

I haven't but am experiencing this on a report. Second ticket with MS Support and they seem clueless.

 

It works fine if I refresh through the desktop app and republish, but refreshing through the service makes those measures show as (blank)

6 REPLIES 6
KHorseman Super Contributor
Super Contributor

Re: A group Measures stop calculating after a refresh

Going to need a lot more details. What are these measures? What is the data source? Do all measures return blank after a refresh or just some? Does the same measure return all blank no matter what the context (different pages, different slicers and filters, etc)? Have you confirmed that the refresh is actually loading usable data?


Did I answer your question? Please mark it as a solution.

Proud to be a Datanaut!
DSimma Regular Visitor
Regular Visitor

Re: A group Measures stop calculating after a refresh

Source is a folder of CSV file with a rather complex data model, everything is perfect in Desktop App. They are somewhat static, updated nightly. I do query a folder and filter that folder down and run combine binaries to bring in monthly files as one table.

 

The measures themselves are very basic, just calculating a percentage, using a Calculate of Countrows to filter divided by Countrows of the table. I have more that add an extra level of filtering.  All within one of the tables, not even passing over a relationship.

 

And yes they all show blank, no matter slicer context, I have them shown as cards on one page and charts on the other, and all show blank. 

 

The Data is fine, and get this, I publish and immediately refresh it, and they go blank, but the data never changed, its the same files. I can republish from the desktop, its fine again, refresh through service and they are blank again.

 

It is definitely a strange one, just curious if someone has seen something like this before.  I am starting to think I need to start a new PBIX file and recreate the model and 30 pages of report which is frustrating.

Highlighted
Moderator v-caliao-msft
Moderator

Re: A group Measures stop calculating after a refresh

@DSimma,

 

For the CSV file data source wihch stored on your local folder, you need a personal gate way refresh your data. The Power BI Gateway - Personal acts as a bridge, providing quick and secure data transfer between the Power BI service and on-premises data sources that support refresh.

 

The personal gateway is only available with Power BI Pro. It installs and runs as a service on your computer. As a service, it runs using a Windows account you  specify during configuration. In some cases, the Gateway runs as an application. 
https://powerbi.microsoft.com/en-us/documentation/powerbi-personal-gateway/

 

So in your scenario, please configure gateway and check if this issue persists or not.

 

Regards,

Charlie Liao

Re: A group Measures stop calculating after a refresh

Hi @DSimma

 

I would double check that after the refresh that there still is data. From your explanation it sounds as if the data is not being fully refreshed, hence having blank measures.

 

Once the refresh has completed, I would edit the report, create another sheet and ensure that the data is still there or does exist in the data model.


Did I answer your question? Mark my post as a solution!
"Proud to be a Datanaut!"
Power BI Blog
DSimma Regular Visitor
Regular Visitor

Re: A group Measures stop calculating after a refresh

I found why they stop calculating, but no explanation as to why as of yet.

 

It seems the desktop app is fine leaving text as text on the refresh, but the Service is changing my text in to true/false values instead, however broken true false as they come through as 0/-1, instead of 0/1.

 

 

 

DSimma Regular Visitor
Regular Visitor

Re: A group Measures stop calculating after a refresh

IT looks like adding transformation steps into my import to force two columns to be text fixed my issue. 

 

The Desktop app left it alone as text, but the Service wanted to convert it to True/False, being that I am looking for text, it wasn't calculating. 

 

Weird discrepency between the system, maybe MS will look into fixing it.

Helpful resources

Announcements
New Kudos Received Badges Coming

New Kudos Received Badges Coming

Kudos to you if you earned one of these! Check your inbox for a notification.

Microsoft Implementation for Communities Wins Award

Microsoft Implementation for Communities Wins Award

Learn about the award-winning innovation that was implemented across Microsoft’s Business Applications Communities.

Power Platform World Tour

Power Platform World Tour

Find out where you can attend!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (2,200)