cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PaperPlanes
Frequent Visitor

500 Internal server error

Hello,

 

Not able to publish a report to the service. Keep getting The remote server returned an error: (500) Internal Server Error

The report was published and worked fine until a couple of weeks ago. 

 

The report could be published neither via Power BI Desktop 

PaperPlanes_0-1594209040934.png

 

nor  Appservice -> Get Data - local file

 

"COM error: Microsoft.MashupEngine, [Expression.Error] We cannot convert the value "" to type Record.."

 

Checked all M-expressions there is no error. All queries are refreshing without errors. 

 

View Trace File 

 

 

 

 

     

 

1 ACCEPTED SOLUTION

Hi @PaperPlanes ,

 

I found that the problem has been fixed, please try again.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

View solution in original post

6 REPLIES 6
v-deddai1-msft
Community Support
Community Support

Hi @PaperPlanes ,

 

I found someone has open support ticket for the same issue. If it is fixed, I will let you know as soon as possible.

 

Best Regards,

Dedmon Dai

 

 

GilbertQ
Super User
Super User

Hi there

What happens if you try and publish the report to the Power BI Service by using Get Data in the Power BI Service?




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

@v-deddai1-msft 

As I've told, I get 

 

"COM error: Microsoft.MashupEngine, [Expression.Error] We cannot convert the value "" to type Record.."

error

 

PaperPlanes_0-1594292180635.png

 

@v-deddai1-msft 

 

Created a brand new PowerBI file, moved everything from the old one to the new one and was able to publish it successfully.

Logged into the Power BI service deleted the newly published report along with its dataset.

Tried to republish the same new report and got the same 500 Internal server error and wasn't able to publish it since.

 

cheers

Hi @PaperPlanes ,

 

I found that the problem has been fixed, please try again.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

View solution in original post

I am getting this same error, however, i am able to publish the report to another premium workspace which leads me to think that the problem is not with the report but with the workspace (which is also premium). We've never had this problem in 3 years. Unfortunately I am not admin on the workspace, have any admin's encountered this problem? If so how was it solved?

Thank you  

SCA01

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power BI October Update 2021.jpg

Power BI Release

Click here to read more about the October 2021 Release!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Teds Dev Camp Oct. 2021 768x460.jpg

Power BI Dev Camp - October 28th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!