cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
andlin11
Regular Visitor

"RS:embed=true" command not working in Sharepoint 2013 when upgrading to PBIRS jan 2020

Hi!
Our iframed Pbix-reports stopped working after upgrading to Power BI Report Server jan 2020.
After upgrading the iframe command no longer accept "rs:embed:true" when linking to a report. 
If I change to rs:embed=false the report shows up again.

 

Content editor Web Part:

 

<iframe width="1320" height="770" src="http://server/reports/reportname?rs:embed=true"></iframe>
Anyone experiencing the same issue after upgrading to PBI RS jan 2020?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
lestagek
Regular Visitor

Re: "RS:embed=true" command not working in Sharepoint 2013 when upgrading to PBIRS jan 202

The CustomHeaders property on the advanced settings of the report server defaults to:

 

<CustomHeaders>
<Header>
<Name>X-Frame-Options</Name>
<Pattern>(.+)((\/api)|(\/(mobilereport|report|powerbi|excel|pages)\/(.+)(rs:embed=true|rc:toolbar=false)))</Pattern>
<Value>SAMEORIGIN</Value>
</Header>
</CustomHeaders>

 

I changed it to:

 

<CustomHeaders><Header><Name>Embed</Name><Pattern>(.+)(/reports/)(.+)(rs:embed=true)</Pattern><Value>True</Value></Header></CustomHeaders>

 

Embedded reports are working now.

 

Connect to the report server via SSMS, right click on the server and server properties.  Click on the Advanced option.

View solution in original post

15 REPLIES 15
ForcaTaico Resolver II
Resolver II

Re: "RS:embed=true" command not working in Sharepoint 2013 when upgrading to PBIRS jan 202

Hi @andlin11 

 

I have the same issue with iframe when using  "rs:embed:true". Also on SharePoint 2013.

 

Regards Taico

lader
Frequent Visitor

Re: "RS:embed=true" command not working in Sharepoint 2013 when upgrading to PBIRS jan 202

I have the same issue. The problem seems to be with the embed function and the iframe.

 

PS: Looking the issue we are having the error Refused to display in a frame because it set 'X-Frame-Options' to 'sameorigin'. This should not happen because we are sending ?rs:embed=true at the end of the URL so the report is embebed. Something changed in the last update. =(

AndreasScholl Helper I
Helper I

Re: "RS:embed=true" command not working in Sharepoint 2013 when upgrading to PBIRS jan 202

Hello all,

 

same here, we used some Iframes within our Intranet (Confluence), all of them are not longer working now.

Is MS working on that or is this no longer supported?

 

BR

Andreas

lestagek
Regular Visitor

Re: "RS:embed=true" command not working in Sharepoint 2013 when upgrading to PBIRS jan 202

The CustomHeaders property on the advanced settings of the report server defaults to:

 

<CustomHeaders>
<Header>
<Name>X-Frame-Options</Name>
<Pattern>(.+)((\/api)|(\/(mobilereport|report|powerbi|excel|pages)\/(.+)(rs:embed=true|rc:toolbar=false)))</Pattern>
<Value>SAMEORIGIN</Value>
</Header>
</CustomHeaders>

 

I changed it to:

 

<CustomHeaders><Header><Name>Embed</Name><Pattern>(.+)(/reports/)(.+)(rs:embed=true)</Pattern><Value>True</Value></Header></CustomHeaders>

 

Embedded reports are working now.

 

Connect to the report server via SSMS, right click on the server and server properties.  Click on the Advanced option.

View solution in original post

AndreasScholl Helper I
Helper I

Re: "RS:embed=true" command not working in Sharepoint 2013 when upgrading to PBIRS jan 202

Thanks for your support, unfortunatley I am missing the option in my advanced settings of the report server...

Any clue on that? 

Thank you!
Andreas

lader
Frequent Visitor

Re: "RS:embed=true" command not working in Sharepoint 2013 when upgrading to PBIRS jan 202

Yes! This is the solution. 

 

You have to change the settings on the custom headers.

More info here: https://docs.microsoft.com/en-us/sql/reporting-services/tools/server-properties-advanced-page-report...

 

@lestagek Thanks!

AndreasScholl Helper I
Helper I

Re: "RS:embed=true" command not working in Sharepoint 2013 when upgrading to PBIRS jan 202

I got it - its within the reporting services properties. Thank you. PRoblem is solved. 

ForcaTaico Resolver II
Resolver II

Re: "RS:embed=true" command not working in Sharepoint 2013 when upgrading to PBIRS jan 202

Never mind my last post (deleted) I was pointing to production server (sep 2019)...

 

Thanks for the solution @lestagek worked like a charm!

 

Would have been nice if MS mentioned it explicitly in the release notes.

 

Regards Taico

 

andlin11
Regular Visitor

Re: "RS:embed=true" command not working in Sharepoint 2013 when upgrading to PBIRS jan 202

Awesome, thank you @lestagek !
A heads up from MS would have been nice.

Thank you for all the input in this tread
Regards Andreas

Helpful resources

Announcements
New Ranks Launched March 24th!

New Ranks Launched March 24th!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power BI Community!

‘Better Together’ Contest Finalists Announced!

‘Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Arun 'Triple A' Event Video, Q&A, and Slides

Arun 'Triple A' Event Video, Q&A, and Slides

Missed the Arun 'Triple A' event or want to revisit it? We've got you covered! Check out the video, Q&A, and slides now.

Join THE global Microsoft Power Platform event series.

Join THE global Power Platform event series.

Attend for two days of expert-led learning and innovation on topics like AI and Analytics, powered by Dynamic Communities.

Community Summit North America

Community Summit North America

Innovate, Collaborate, Grow. The top training and networking event across the globe for Microsoft Business Applications

Top Kudoed Authors