cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate I
Advocate I

Word Wrap disappearing when report published to Report Server

Created a report using PBI Desktop, and took about an hour to get the column headings right on this matrix, as I have three matrixes showing the same columns, but from different sources and can't find a way to make all of the headings the same size.  However, it looks ok, and most of the headings are wrapped.  

Wrapped.PNG

But when I publish this to my report server, the word wrap disappears.

Not Wrapped.PNG

Any suggestions gratefully received (mostly concerned about the word wrap not happening on the server)

 

EDIT***  Forgot to say in my original post that I have tried turning off column auto resize on the the report, made no diffierence.

1 ACCEPTED SOLUTION

Accepted Solutions

It looks like the update (2018 March) solved the problem, likely it was a bug which got fixed.

 

What I noticed is that when I opened my reports with the updated desktop app, the "Word Wrap" was OFF, I set it to ON, uploaded it, and it worked.

View solution in original post

20 REPLIES 20
Microsoft
Microsoft

Hi @SkinnyPete63,

 

Based on my test, to keep the column headers wrapped after being published to Report Server, we should turn on the "Auto-size column width".

1.PNG2.PNG

 

Best regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Yuliana

 

Thanks for your response, but your solution does not work.  Even if it did, as soon as I refresh my report, I lose all of my column widths.

 

Just to check, here is where I have set the option you mention;

 

Setting Word Wrap.PNG

 

And when I publish, the headings are not word wrapped.

Hi @SkinnyPete63,

 

You should turn on the "Auto-size column width" option, meanwhile, turn on the "Word wrap".

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Frequent Visitor

Hi @SkinnyPete63,

 

Not a solution, but just to say I have the exact same problem. I believe it's a Server problem. The word wrap functionallity doesn;t seem to work for column headers, values... not even for card visuals.

 

Regards,

Cristina

Thank you @CristinaLia, at least I know I am not going mad!

Thanks again @v-yulgu-msft, but I have tried all combinations of this, and my server still won't show wrapped column headings.

Hi @SkinnyPete63,

 

Please change a different browser for a test.

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-yulgu-msft

 

Thanks for the feedback.  I have tested with Chrome, Firefox and IE11, none of which wrapp the column headings.

 

Just a thought, could it be because my report server is the development version, rather than the production version?  We have not set up our production server yet, which is why we are using a development licence at the moment.

Hi @SkinnyPete63,

 

Just wanted to say that I tried overwriting my report a few times, and all visuals where I have used word wrap now work. maybe you could give it a go?

 

Regards,

Cristina

Helpful resources

Announcements
November Update

Check it Out!

Click here to read more about the November 2020 Updates!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

secondImage

Power Platform October Community Highlights

Check out the top community contributors across all of the communities

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.