cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
emuraoka
Frequent Visitor

Using the filter pane when a PBIRS report is still loading breaks it (blanks the report page)

Hi, 

We are facing a weird problem with our reports deployed in PBIRS. When loading the report if you try to use the filters on the filter pane, before the report is fully loaded, the whole report turns blank and a page refresh is required (or reopen the report).

Same thing doesn't happen on Power BI Service only on PBIRS.

Anyone having/noticed this issue?

Thanks, 

Eduardo

 

1 ACCEPTED SOLUTION

Hi @d_gosbell,

 

Sorry for the late reply. I was trying to gather more info and see if I could find/get any logging on the problem.

We just installed the latest update(September 2019) for report server and it looks like it fixed the problem.

 

Thanks for your help.

 

Cheers,

 

Eduardo

View solution in original post

5 REPLIES 5
emuraoka
Frequent Visitor

Please let me know if more details and/or clarification is required. 

I'm assuming by the date of your post that you are talking about the "black" filters pane on the right hand side of the May 2019 Portal - is this correct?

 

I just tried this and was not able to reproduce this issue.

 

Are you able to share a screenshot of what you are doing? Maybe I was not reproducing exactly the same situation.

Yes, that's correct, the black filters pane on the right hand side is the one that I'm talking about.

 

Here are 2 screenshots of when I'm hitting the filter:

before.png

 and after:

after.png

The report takes around 5 secs to fully load, and the problem does not happen when is fully loaded.

Users that use this report on a daily base, don't wanna wait untill is fully loaded, because they didn't have to when the report was in Power BI Service.

 

Thanks for your help and please let me know if you need more info or maybe a screen captured video of the problem.

 

Cheers,

 

Eduardo

Sorry, but I'm not really sure what is causing this for you. I can't reproduce this issue. I was wondering if you had maybe tried to use the cloud version of Power BI Desktop to try and use the new "white" filter pane style on the May 2019 release of PBIRS. I've heard of a few people trying this, but it is unsupported and could lead to behaviours like this.

 

Are you using any 3rd party visuals? Have you tried opening the browser developer tools and checking the javascript console (my guess is that you will probably see some javascript errors which are blocking the page refresh) if these are coming from a 3rd party visual maybe check for an updated version...

Hi @d_gosbell,

 

Sorry for the late reply. I was trying to gather more info and see if I could find/get any logging on the problem.

We just installed the latest update(September 2019) for report server and it looks like it fixed the problem.

 

Thanks for your help.

 

Cheers,

 

Eduardo

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.