cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
xhinobi
Advocate I
Advocate I

URL filters not working after PBIRS Jan 2021 update

Hi:

Url filters are not working after PBIRS 2021 jan update. Now returns a blank screen , the reports works removing the ?filter expression.

Any workaround?

 

1 ACCEPTED SOLUTION
Petebro
Microsoft
Microsoft

This has been fixed in an update for Power BI Report Server (Jan 2021)

 

https://www.microsoft.com/en-us/download/details.aspx?id=55329

 

    - *Version: 1.10.7737.32652 (Build 15.0.1105.230), Released: March 12, 2021*
        - Bug fixes
            - Fixed issue with URL filters causing PBIX reports to not load.
 
 

View solution in original post

33 REPLIES 33

Thanks for the update, but yes, this did dash my hopes :(. 

 

When you say this will be fixed in the next release do you mean like May Release or a potential updated build in between? 

Petebro
Microsoft
Microsoft

Hi we have a fix for this issue but unfortuately now there a few other outstanding bugs that we would want to include in any sort of update as well. Not quite sure of timing but it will be fixed in future updates to PBIRS.

@Petebro Noticed that there is a new build of ReportServer posted today. Does it fix this issue by any chance? 

vickyd_0-1613144019231.png

 

oh, @Petebro  I planned production rollout of January 21, 2021 version for this weekend. Because I expected no new build soon.

Please is there new build ongoing or it is some typo?

No new build, as I said below it is the same version with just some metadata updates on the download page.

Hi @Petebro ,

good luck, we have January release (of October release) and have later January relese of January release, which is labeled as February release 😉

 

Another question. I still waiting to some reposnse to another issue: https://community.powerbi.com/t5/Report-Server/Disabled-quot-Parallel-loading-of-tables-quot-is-not-... 

Please is possible confirm if this issue is tracked by MS?

yeddes_ahmed
Regular Visitor

Hi
we have the same problem , 

Petebro
Microsoft
Microsoft

I was able to reproduce the blank screen myself and have filed a bug for investigation. Thanks for reporting it and I'll let you know an ETA if I am able to.

I'm using URL filters in one of my products where Power BI plays an important role.

 

Hope this gets fixed in the very near future ... via a hot fix and not in 3-4 months!

 

Is there some news on this issue?

 

 

Hi Petebro,

Is it possible to obtain a FIX?
Two customers have the same issue and are very disapointed.


Regards 

It's nice to see we are not the only ones, @Petebro  looks like it has been a month, any update on this in the near future?

Hi @Petebro ,

is know an ETA for this issue?

Thanks...

Having same issue, after upgrading to Jan 2021, after adding a "?filter" expression to the url, the report returns a blank screen....has this already been reported as a bug?

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.