cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Today() is showing incorrect value in portal

hi, I have a report with a table column defiend as follow:

ProcessDate = TODAY()
 
this is working perfectly fine in my report within Power BI Desktop.
However, after I published this report to Power Bi portal, for some odd reason, it always shows a static incorrect value.
What I meant "incorrect static value" is that, I uploaded the report to power bi portal on 10.24.19.
but when I checked this value on 10.24.19 and 10.25.19, it always shows the value of 10.21.19.
this issue only occur on report published to PowerBI portal, and doesn't repro on Power Bi Desktop.

Anyone else has the same experience? Any known fix or workaround?
 
Thanks
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

I am not sure why Today() is not working in the portal, but I just replaced it with Now() and it is now working as expected in both desktop and portal.

View solution in original post

1 REPLY 1
New Member

I am not sure why Today() is not working in the portal, but I just replaced it with Now() and it is now working as expected in both desktop and portal.

View solution in original post

Helpful resources

Announcements
November Update

Check it Out!

Click here to read more about the November 2020 Updates!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

secondImage

Power Platform October Community Highlights

Check out the top community contributors across all of the communities

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors